summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRetro_Gamer2022-05-19 08:08:54 -0400
committerRetro_Gamer2022-05-19 08:08:54 -0400
commita7e56e90fa2a7d3d1a6945099c6eef48445a9680 (patch)
treec92396a05fa51e9a93b67f5c03d70bad138da9f8
parent28c21e1de5acd6c985461d8df5e9472e02baea96 (diff)
downloadaur-a7e56e90fa2a7d3d1a6945099c6eef48445a9680.tar.gz
vcpkg & info updates
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e91e25019520..ae8440486fb2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = trenchbroom-git
pkgdesc = TrenchBroom is a modern cross-platform level editor for Quake-engine based games.
- pkgver = v2021.1.r67.ga78fa3bc3
- pkgrel = 2
- url = http://kristianduske.com/trenchbroom
+ pkgver = main_branch
+ pkgrel = 1
+ url = https://trenchbroom.github.io/
arch = i686
arch = x86_64
license = GPLv3
@@ -23,10 +23,9 @@ pkgbase = trenchbroom-git
depends = glm
provides = trenchbroom
conflicts = trenchbroom
- source = trenchbroom::git+https://github.com/kduske/TrenchBroom.git#branch=master
+ source = trenchbroom::git+https://github.com/TrenchBroom/TrenchBroom.git#branch=master
source = trenchbroom.desktop
sha1sums = SKIP
sha1sums = 028252ac86ec7f733e94589062eb316224887bd4
pkgname = trenchbroom-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 978a07e4fa47..691986b7e6b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
# Maintainer: Hauke Rehfeld <aur@haukerehfeld.de>
+# Contributor: Retro Gamer <https://github.com/eGax>
pkgname=trenchbroom-git
-pkgver=v2021.1.r67.ga78fa3bc3
-pkgrel=2
+pkgver=main_branch
+pkgrel=1
pkgdesc="TrenchBroom is a modern cross-platform level editor for Quake-engine based games."
arch=("i686" "x86_64")
-url="http://kristianduske.com/trenchbroom"
+url="https://trenchbroom.github.io/"
license=("GPLv3")
makedepends=("git" "pandoc" "qt5-base" "cmake" "ninja" "qt5-svg" "libxcb")
@@ -13,7 +14,7 @@ depends=("freeimage" "freetype2" "mesa" "libgl" "freeglut" "libxxf86vm" "glew" "
conflicts=("trenchbroom")
provides=("trenchbroom")
-source=("trenchbroom::git+https://github.com/kduske/TrenchBroom.git#branch=master"
+source=("trenchbroom::git+https://github.com/TrenchBroom/TrenchBroom.git#branch=master"
trenchbroom.desktop)
sha1sums=('SKIP'
@@ -36,7 +37,7 @@ _BUILDDIR=build
build() {
mkdir -p "$_BUILDDIR"
cd "$_BUILDDIR"
- cmake "$srcdir/trenchbroom" -DCMAKE_INSTALL_PREFIX:PATH=/usr -DCMAKE_BUILD_TYPE=Release
+ cmake "$srcdir/trenchbroom" -DCMAKE_INSTALL_PREFIX:PATH=/usr -DCMAKE_BUILD_TYPE=Release -DCMAKE_PREFIX_PATH="cmake/packages" -DCMAKE_TOOLCHAIN_FILE="vcpkg/scripts/buildsystems/vcpkg.cmake"
# we were running into weird xcb errors, which made this necessary to force headless builds
# might be useful incase you ARE building on a headless system
#QT_QPA_PLATFORM=offscreen cmake --build . --target TrenchBroom