summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKenny Stier2020-04-11 23:36:56 -0400
committerKenny Stier2020-04-11 23:36:56 -0400
commit77220de4474e9bdbccad2138459989394be8a445 (patch)
tree6f9977962afa15df9e794fb349a77be09444dbd6
downloadaur-trenta-icons.tar.gz
Branding change, first commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eca38dcdffd3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = trenta-icons
+ pkgdesc = A crisp, modern icon theme for Trenta OS.
+ pkgver = 0.r448.c217cf9
+ pkgrel = 1
+ url = https://github.com/trenta-io/trenta-icons
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = bash
+ provides = trenta-icons
+ conflicts = trenta-icons
+ replaces = rainier-ui-icons-git
+ options = !strip
+ source = trenta-icons::git+https://github.com/trenta-io/trenta-icons.git
+ sha256sums = SKIP
+
+pkgname = trenta-icons
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09037f55adfa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer : Kenneth Stier <kenny@trenta.io>
+
+pkgname=trenta-icons
+pkgver=0.r448.c217cf9
+pkgrel=1
+pkgdesc='A crisp, modern icon theme for Trenta OS.'
+arch=('any')
+url='https://github.com/trenta-io/trenta-icons'
+license=('GPL3')
+depends=('bash')
+makedepends=('git')
+provides=('trenta-icons')
+conflicts=('trenta-icons')
+replaces=('rainier-ui-icons-git')
+options=('!strip')
+source=('trenta-icons::git+https://github.com/trenta-io/trenta-icons.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd trenta-icons
+ echo "0.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd trenta-icons/usr/share/icons/
+ install -dm 755 "${pkgdir}"/usr/share/icons
+ cp -dr --no-preserve='ownership' Trenta "${pkgdir}"/usr/share/icons/
+}