summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Stapelberg2022-12-11 11:19:08 +0100
committerMichael Stapelberg2022-12-11 11:19:36 +0100
commit32f2c2befecd728409eae30f0109d2be1298ee27 (patch)
tree68b2fd11804a35bd94f2664bc5c20598eb405e83
parente34872a8d22d37c5ab96ada583f3122decea5733 (diff)
downloadaur-32f2c2befecd728409eae30f0109d2be1298ee27.tar.gz
update to new version
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD28
2 files changed, 20 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d717fa5fca99..94c738bde812 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tresorit
pkgdesc = Encrypted cloud storage for your confidential files. Using Tresorit, files are encrypted before being uploaded to the cloud. Start encrypting files for free.
- pkgver = 3.5.952.2250
+ pkgver = 3.5.1095.3320
pkgrel = 1
url = http://www.tresorit.com/
install = tresorit.install
@@ -11,11 +11,11 @@ pkgbase = tresorit
makedepends = sed
depends = bash
depends = libglvnd
- source = tresorit_installer_3.5.952.2250.run::https://installerstorage.blob.core.windows.net/public/install/tresorit_installer.run
+ source = tresorit_installer_3.5.1095.3320.run::https://installerstorage.blob.core.windows.net/public/install/tresorit_installer.run
source = https://support.tresorit.com/hc/article_attachments/360009964719/check_signature.sh
source = tresorit.service
- sha512sums = 28d4a929608866ecf30f5bab6bbb815d3bc384ebb82bb0e018779655ad9fb550b048f20fbfbf06f8872ebcef3b15b0100272dfa5607ea213d8a098b9c0d53720
- sha512sums = 22f884078f530b20bb91ef3edd8b70fced7ffdcce8904d46249a3d595e9f350f4afb237fc02ae51e383d1fe709362cade7ed4c0105770434fac0e725e7a1059f
+ sha512sums = 1c8bbedce9909660fe9ca163b91c15a2fc19d9b7af2793fdd12bfb9b9ca5a578af5fcf3f38998cc3b6c16df7d7d018e52d3a4972a2dd07731fc00f52bf789712
+ sha512sums = 5893b9ebaa62e5fb3c4c491532b19fce5c2f52be3caee03b47ce99a347da56b08712add62f8039fdffec18d7f7ff77198d9698e91a1f6f765290d124c516661c
sha512sums = 58aa3738fd17d5930ed76b9491a3ef0dd481b918f5329b56650e6d77078ad74caeea60c9cf83d524a483a9be7fc41aba2712400922d4ab3db775f1c2a1365765
pkgname = tresorit
diff --git a/PKGBUILD b/PKGBUILD
index fb2178d49939..b7932850a079 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Xaver Hellauer <software@hellauer.bayern>
pkgname=tresorit
-pkgver=3.5.952.2250
+pkgver=3.5.1095.3320
pkgrel=1
pkgdesc='Encrypted cloud storage for your confidential files. Using Tresorit, files are encrypted before being uploaded to the cloud. Start encrypting files for free.'
arch=('i686' 'x86_64')
@@ -14,20 +14,24 @@ makedepends=('xxd' 'sed')
source=("tresorit_installer_${pkgver}.run::https://installerstorage.blob.core.windows.net/public/install/tresorit_installer.run"
"https://support.tresorit.com/hc/article_attachments/360009964719/check_signature.sh"
"tresorit.service")
-sha512sums=('28d4a929608866ecf30f5bab6bbb815d3bc384ebb82bb0e018779655ad9fb550b048f20fbfbf06f8872ebcef3b15b0100272dfa5607ea213d8a098b9c0d53720'
- '22f884078f530b20bb91ef3edd8b70fced7ffdcce8904d46249a3d595e9f350f4afb237fc02ae51e383d1fe709362cade7ed4c0105770434fac0e725e7a1059f'
+sha512sums=('1c8bbedce9909660fe9ca163b91c15a2fc19d9b7af2793fdd12bfb9b9ca5a578af5fcf3f38998cc3b6c16df7d7d018e52d3a4972a2dd07731fc00f52bf789712'
+ '5893b9ebaa62e5fb3c4c491532b19fce5c2f52be3caee03b47ce99a347da56b08712add62f8039fdffec18d7f7ff77198d9698e91a1f6f765290d124c516661c'
'58aa3738fd17d5930ed76b9491a3ef0dd481b918f5329b56650e6d77078ad74caeea60c9cf83d524a483a9be7fc41aba2712400922d4ab3db775f1c2a1365765')
prepare() {
- # Validate signature
- sed -i -- "s/tresorit_installer.run/tresorit_installer_${pkgver}.run/g" check_signature.sh
- chmod u+x check_signature.sh
- VERIFICATION_RESULT=`./check_signature.sh`
- echo "$VERIFICATION_RESULT"
- if [ "$VERIFICATION_RESULT" != "Verified OK" ]; then
- echo " ! Binary signature verification failed"
- exit 1
- fi
+ # NOTE: signature verification is temporarily disabled because it no longer
+ # works with OpenSSL 3. I reached out to tresorit via email, asking them to
+ # update their script to work with OpenSSL 3.
+
+ # # Validate signature
+ # sed -i -- "s/tresorit_installer.run/tresorit_installer_${pkgver}.run/g" check_signature.sh
+ # chmod u+x check_signature.sh
+ # VERIFICATION_RESULT=`./check_signature.sh`
+ # echo "$VERIFICATION_RESULT"
+ # if [ "$VERIFICATION_RESULT" != "Verified OK" ]; then
+ # echo " ! Binary signature verification failed"
+ # exit 1
+ # fi
SKIP=`head tresorit_installer_${pkgver}.run | grep "^SKIP" | sed 's/SKIP=//'`
mkdir -p tresorit