summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXaver Hellauer2018-10-01 10:21:53 +0200
committerXaver Hellauer2018-10-01 10:21:53 +0200
commit924f5b3ee3018d76c3858924f2bac178f826553f (patch)
tree1720e8fe4280c5eb3da49509d0077f41843e747f
parenta55383e8725db0354b5b1ee2bb9e22b608796485 (diff)
downloadaur-924f5b3ee3018d76c3858924f2bac178f826553f.tar.gz
3.5.600.797
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD14
3 files changed, 16 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8708971ccfad..cd45073f4ffe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tresorit
pkgdesc = Encrypted cloud storage for your confidential files. Using Tresorit, files are encrypted before being uploaded to the cloud. Start encrypting files for free.
- pkgver = 3.5.550.777
+ pkgver = 3.5.600.797
pkgrel = 1
url = http://www.tresorit.com/
install = tresorit.install
@@ -8,11 +8,14 @@ pkgbase = tresorit
arch = x86_64
license = custom:tresorit
makedepends = xxd
+ makedepends = sed
depends = bash
depends = libglvnd
- source = tresorit_installer_3.5.550.777.run::https://installerstorage.blob.core.windows.net/public/install/tresorit_installer.run
+ source = tresorit_installer_3.5.600.797.run::https://installerstorage.blob.core.windows.net/public/install/tresorit_installer.run
+ source = https://support.tresorit.com/hc/en-us/article_attachments/360013145193/check_signature.sh
source = tresorit.service
- sha512sums = SKIP
+ sha512sums = fc22318d45e3763a68466342f6b22121a62cdea743cf720caf0e21ad3c1214db5296e0439e24161bcaa27da3c39e51a532003db547d14ba9938f50fd50a7f2b5
+ sha512sums = ad5876d1477fd20ecbbd18ceeda41aa89f8faa08ea4ce5899e441942a1d777b34a5621181853730688bef0b9b7892ab1058b9ba0de2b22c3b72444b867827e65
sha512sums = 58aa3738fd17d5930ed76b9491a3ef0dd481b918f5329b56650e6d77078ad74caeea60c9cf83d524a483a9be7fc41aba2712400922d4ab3db775f1c2a1365765
pkgname = tresorit
diff --git a/.gitignore b/.gitignore
index 890c36d30b22..b06e409e608d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,3 +4,4 @@ pkg
*.tar.xz
*.src.tar.gz
tresorit_installer*.run
+check_signature.sh
diff --git a/PKGBUILD b/PKGBUILD
index 9394a67a04e0..f6031f34a9dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Xaver Hellauer <software@hellauer.bayern>
pkgname=tresorit
-pkgver=3.5.550.777
+pkgver=3.5.600.797
pkgrel=1
pkgdesc='Encrypted cloud storage for your confidential files. Using Tresorit, files are encrypted before being uploaded to the cloud. Start encrypting files for free.'
arch=('i686' 'x86_64')
@@ -9,17 +9,21 @@ url="http://www.tresorit.com/"
install=tresorit.install
license=('custom:tresorit')
depends=(bash libglvnd)
-makedepends=('xxd')
+makedepends=('xxd' 'sed')
source=("tresorit_installer_${pkgver}.run::https://installerstorage.blob.core.windows.net/public/install/tresorit_installer.run"
+ "https://support.tresorit.com/hc/en-us/article_attachments/360013145193/check_signature.sh"
"tresorit.service")
-sha512sums=('SKIP'
+sha512sums=('fc22318d45e3763a68466342f6b22121a62cdea743cf720caf0e21ad3c1214db5296e0439e24161bcaa27da3c39e51a532003db547d14ba9938f50fd50a7f2b5'
+ 'ad5876d1477fd20ecbbd18ceeda41aa89f8faa08ea4ce5899e441942a1d777b34a5621181853730688bef0b9b7892ab1058b9ba0de2b22c3b72444b867827e65'
'58aa3738fd17d5930ed76b9491a3ef0dd481b918f5329b56650e6d77078ad74caeea60c9cf83d524a483a9be7fc41aba2712400922d4ab3db775f1c2a1365765')
prepare() {
# Validate signature
- head -c1044 tresorit_installer_${pkgver}.run | tail -c+20 | xxd -r -p > tresorit_installer_${pkgver}.run.signature
- VERIFICATION_RESULT=`tail -c+1046 tresorit_installer_${pkgver}.run | openssl sha512 -verify ../tresorit_installer.run.pubkey -sigopt rsa_padding_mode:pss -sigopt rsa_pss_saltlen:-1 -signature tresorit_installer_${pkgver}.run.signature`
+ sed -i -- "s/tresorit_installer.run/tresorit_installer_${pkgver}.run/g" check_signature.sh
+ chmod u+x check_signature.sh
+ VERIFICATION_RESULT=`./check_signature.sh`
+ echo "$VERIFICATION_RESULT"
if [ "$VERIFICATION_RESULT" != "Verified OK" ]; then
echo " ! Binary signature verification failed"
exit 1