summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanny Su2015-12-21 10:45:33 -0800
committerDanny Su2015-12-21 10:45:33 -0800
commitac6329d6263a8160db3b1149cae39b47d4ce6b97 (patch)
tree25cfce903a270b11a1bf1dbd69785e505412f8a0
downloadaur-ac6329d6263a8160db3b1149cae39b47d4ce6b97.tar.gz
Initial Commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD42
-rwxr-xr-xarchlinux_user_install13
-rwxr-xr-xsystemd_runner3
-rw-r--r--tresorit.install32
-rw-r--r--tresorit_user.service10
7 files changed, 122 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4f4cab9346d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Mon Dec 21 18:45:20 UTC 2015
+pkgbase = tresorit
+ pkgdesc = Encrypted cloud storage for your confidential files. Using Tresorit, files are encrypted before being uploaded to the cloud. Start encrypting files for free.
+ pkgver = 1.0.125.402
+ pkgrel = 1
+ url = http://www.tresorit.com/
+ install = tresorit.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ source = https://installerstorage.blob.core.windows.net/public/install/tresorit_installer.run
+ sha1sums = d9a5c88a983bd1945b67a231393771e53b8a5912
+
+pkgname = tresorit
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2f67c92447a7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+src
+pkg
+*.zip
+*.tar.xz
+*.src.tar.gz
+tresorit_installer.run
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..72b3fe925082
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Danny Su <contact@dannysu.com>
+
+pkgname=tresorit
+pkgver=1.0.125.402
+pkgrel=1
+pkgdesc='Encrypted cloud storage for your confidential files. Using Tresorit, files are encrypted before being uploaded to the cloud. Start encrypting files for free.'
+arch=('i686' 'x86_64')
+url="http://www.tresorit.com/"
+install=tresorit.install
+license=('custom')
+optdepends=()
+source=("https://installerstorage.blob.core.windows.net/public/install/tresorit_installer.run")
+
+sha1sums=('d9a5c88a983bd1945b67a231393771e53b8a5912')
+
+prepare() {
+ SKIP=`head tresorit_installer.run | grep "^SKIP" | sed 's/SKIP=//'`
+ mkdir -p tresorit
+ tail -n+$SKIP tresorit_installer.run | tar xz -C tresorit
+}
+
+package() {
+ mkdir -p "$pkgdir/opt/tresorit"
+ install -Dm755 ../archlinux_user_install "$pkgdir/opt/tresorit/archlinux_user_install"
+ install -Dm755 ../systemd_runner "$pkgdir/opt/tresorit/systemd_runner"
+
+ if [ $CARCH == "x86_64" ]; then
+ cp -r ./tresorit/tresorit_x64/* "$pkgdir/opt/tresorit"
+ else
+ cp -r ./tresorit/tresorit_x86/* "$pkgdir/opt/tresorit"
+ fi
+
+ echo "Exec=\$HOME/.local/share/tresorit/tresorit" >> "${pkgdir}"/opt/tresorit/tresorit.desktop
+ echo "Icon=/opt/tresorit/tresorit.png" >> "${pkgdir}"/opt/tresorit/tresorit.desktop
+
+ mkdir -p "${pkgdir}"/usr/share/licenses/tresorit
+ ln -s /opt/tresorit/LICENSES.txt \
+ "${pkgdir}"/usr/share/licenses/tresorit/LICENSE
+
+ # install systemd units
+ install -Dm644 ../tresorit_user.service "${pkgdir}"/usr/lib/systemd/user/tresorit.service
+}
diff --git a/archlinux_user_install b/archlinux_user_install
new file mode 100755
index 000000000000..8c3f0d231a4a
--- /dev/null
+++ b/archlinux_user_install
@@ -0,0 +1,13 @@
+#!/bin/sh
+
+SRC_DIR="/opt/tresorit"
+DST_DIR="$HOME/.local/share/tresorit"
+
+mkdir -p $DST_DIR
+cp $SRC_DIR/tresorit $DST_DIR
+cp $SRC_DIR/libTresorit.so $DST_DIR
+cp -r $SRC_DIR/fonts $DST_DIR
+
+mkdir -p "$HOME/.local/share/applications"
+cp /opt/tresorit/tresorit.desktop "$HOME/.local/share/applications/tresorit.desktop"
+sed -i "s|\$HOME|$HOME|" "$HOME/.local/share/applications/tresorit.desktop"
diff --git a/systemd_runner b/systemd_runner
new file mode 100755
index 000000000000..4d5e1be9047e
--- /dev/null
+++ b/systemd_runner
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+$HOME/.local/share/tresorit/tresorit --hidden
diff --git a/tresorit.install b/tresorit.install
new file mode 100644
index 000000000000..d6f23de04e72
--- /dev/null
+++ b/tresorit.install
@@ -0,0 +1,32 @@
+post_install() {
+post_upgrade
+}
+
+post_upgrade() {
+cat << EOF
+
+NOTE: You need to run the script below to finish setting things up for your user account.
+
+/opt/tresorit/archlinux_user_install
+
+
+To reload user systemd modules: systemctl --user daemon-reload
+To start tresorit manually: systemctl --user start tresorit
+To autostart tresorit on user login: systemctl --user enable tresorit
+
+EOF
+}
+
+post_remove() {
+cat << EOF
+
+NOTE: To fully clean up you should also remove the following directory if you don't need your tresorit data anymore:
+
+\$HOME/.local/share/tresorit
+
+Also remove the application shortcut:
+
+\$HOME/.local/share/applications/tresorit.desktop
+
+EOF
+}
diff --git a/tresorit_user.service b/tresorit_user.service
new file mode 100644
index 000000000000..5869cccf965a
--- /dev/null
+++ b/tresorit_user.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Tresorit per-user service
+After=network.target
+
+[Service]
+ExecStart=/opt/tresorit/systemd_runner
+Restart=on-abort
+
+[Install]
+WantedBy=default.target