summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Trnka2018-05-25 13:21:26 +0200
committerJakub Trnka2018-05-25 13:25:12 +0200
commitf27a63117e286da5fa3b6a6ac00f625620bd9324 (patch)
tree6b199e71b897e218252230160ed0474b41ad1c9e
parent8f505d8e58b1140eb92827ff3061d7bb3fb1cffb (diff)
downloadaur-f27a63117e286da5fa3b6a6ac00f625620bd9324.tar.gz
Upgrade to version 2.0.13, source package URL update to https://wallet.trezor.io
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
-rw-r--r--trezor-bridge-bin.install4
3 files changed, 23 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a2dfc30a81d..4b5da17c2f4a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,8 @@
-# Generated by mksrcinfo v8
-# Fri Aug 25 01:30:06 UTC 2017
pkgbase = trezor-bridge-bin
- pkgdesc = Standalone application to use the trezor hardware bitcoin wallet with your computer
- pkgver = 1.2.1
- pkgrel = 1
- url = https://mytrezor.com/
+ pkgdesc = Communication daemon for TREZOR
+ pkgver = 2.0.13
+ pkgrel = 2
+ url = https://trezor.io/
install = trezor-bridge-bin.install
arch = i686
arch = x86_64
@@ -12,10 +10,10 @@ pkgbase = trezor-bridge-bin
depends = curl
depends = libmicrohttpd
depends = libusb
- source_i686 = https://wallet.mytrezor.com/data/bridge/1.2.1/trezor-bridge_1.2.1_i386.deb
- sha256sums_i686 = 1f0b10541e5a9f54bc73aa0d985233d2d4c88f391fb7997633a035ed286ceb55
- source_x86_64 = https://wallet.mytrezor.com/data/bridge/1.2.1/trezor-bridge_1.2.1_amd64.deb
- sha256sums_x86_64 = 7544eae4f1fd0238bfd67ec908925da2a94824167f500e4fa91d9764a2c7f7c7
+ source_i686 = https://wallet.trezor.io/data/bridge/2.0.13/trezor-bridge_2.0.13_i386.deb
+ sha256sums_i686 = fe05d59355d5e9f6559ec60e7e34c286fa30e88595e9661705ee8906d254fcb8
+ source_x86_64 = https://wallet.trezor.io/data/bridge/2.0.13/trezor-bridge_2.0.13_amd64.deb
+ sha256sums_x86_64 = c6765871c59e1b9e158f06664ef55d659fe5ef7e38bef3a64eb6c8f4e799d271
pkgname = trezor-bridge-bin
diff --git a/PKGBUILD b/PKGBUILD
index b04509ea17bc..371d0fba1d17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,28 @@
-# Maintainer: Sebastian Jug <sebastianDOTjugATgmailDOTcom>
-#
+# Maintainer: Jakub Trnka <jakub.trnka@chainanalytics.net>
pkgname=trezor-bridge-bin
-pkgver=1.2.1
-pkgrel=1
-pkgdesc="Standalone application to use the trezor hardware bitcoin wallet with your computer"
+pkgver=2.0.13
+pkgrel=2
+pkgdesc="Communication daemon for TREZOR"
arch=('i686' 'x86_64')
-url="https://mytrezor.com/"
+url="https://trezor.io/"
license=('LGPL3')
depends=('curl' 'libmicrohttpd' 'libusb')
makedepends=()
options=()
install=$pkgname.install
-source_i686=("https://wallet.mytrezor.com/data/bridge/${pkgver}/trezor-bridge_${pkgver}_i386.deb")
-source_x86_64=("https://wallet.mytrezor.com/data/bridge/${pkgver}/trezor-bridge_${pkgver}_amd64.deb")
-sha256sums_i686=('1f0b10541e5a9f54bc73aa0d985233d2d4c88f391fb7997633a035ed286ceb55')
-sha256sums_x86_64=('7544eae4f1fd0238bfd67ec908925da2a94824167f500e4fa91d9764a2c7f7c7')
+source_i686=("https://wallet.trezor.io/data/bridge/${pkgver}/trezor-bridge_${pkgver}_i386.deb")
+source_x86_64=("https://wallet.trezor.io/data/bridge/${pkgver}/trezor-bridge_${pkgver}_amd64.deb")
+sha256sums_i686=('fe05d59355d5e9f6559ec60e7e34c286fa30e88595e9661705ee8906d254fcb8')
+sha256sums_x86_64=('c6765871c59e1b9e158f06664ef55d659fe5ef7e38bef3a64eb6c8f4e799d271')
package() {
msg2 "Extracting the data..."
bsdtar -xf data.tar.gz -C "$pkgdir/"
msg2 "Fixing file structure..."
- mv "$pkgdir"/lib/udev/ "$pkgdir"/usr/lib/
+ mv "$pkgdir"/lib/udev "$pkgdir"/usr/lib/
- msg2 "Removing init scripts, and cleaning up..."
- rm -r "$pkgdir"/etc/ "$pkgdir"/lib/
+ msg2 "Cleaning up..."
+ rm -r "$pkgdir"/lib/
}
diff --git a/trezor-bridge-bin.install b/trezor-bridge-bin.install
index 5b2d34b5f95f..0cf06de9b1a4 100644
--- a/trezor-bridge-bin.install
+++ b/trezor-bridge-bin.install
@@ -2,7 +2,9 @@
pre_install() {
getent group trezord >/dev/null || groupadd -r trezord
- getent passwd trezord >/dev/null || useradd -r -g trezord -d /var -s /sbin/nologin -c "TREZOR Bridge" trezord
+ getent group plugdev >/dev/null || groupadd -r plugdev
+ getent passwd trezord >/dev/null || useradd -r -g trezord -d /var -s /usr/bin/nologin -c "TREZOR Bridge" trezord
+ usermod -a -G plugdev trezord
touch /var/log/trezord.log
chown trezord:trezord /var/log/trezord.log
chmod 660 /var/log/trezord.log