summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Booth2015-06-23 09:47:26 -0700
committerBen Booth2015-06-23 09:47:26 -0700
commit15f743870ec7c9ff0dbc83466491511ae02f2989 (patch)
tree03988e367f9e6518d7e1b50579bc99258ba6e9ce
downloadaur-15f743870ec7c9ff0dbc83466491511ae02f2989.tar.gz
Initial import
-rw-r--r--.AURINFO14
-rw-r--r--.SRCINFO17
-rw-r--r--LICENSE12
-rw-r--r--PKGBUILD24
4 files changed, 67 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..6232dae9260d
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,14 @@
+pkgbase = trf
+ pkgdesc = Tandem repeats finder: a program to analyze DNA sequences
+ pkgver = 4.07b
+ pkgrel = 3
+ url = http://tandem.bu.edu/trf/trf.html
+ arch = i686
+ arch = x86_64
+ license = custom
+ source = trf407b.linux64::http://tandem.bu.edu/cgi-bin/trf/trf.download.pl?fileselect=26
+ source = trf407b.linux::http://tandem.bu.edu/cgi-bin/trf/trf.download.pl?fileselect=27
+ source = LICENSE
+
+pkgname = trf
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..14666b660195
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = trf
+ pkgdesc = Tandem repeats finder: a program to analyze DNA sequences
+ pkgver = 4.07b
+ pkgrel = 3
+ url = http://tandem.bu.edu/trf/trf.html
+ arch = i686
+ arch = x86_64
+ license = custom
+ source = trf407b.linux64::http://tandem.bu.edu/cgi-bin/trf/trf.download.pl?fileselect=26
+ source = trf407b.linux::http://tandem.bu.edu/cgi-bin/trf/trf.download.pl?fileselect=27
+ source = LICENSE
+ md5sums = 26d83513f43f1456542123c6fe8eecf2
+ md5sums = 1b986c2e32d94be7f2357183f3154bce
+ md5sums = 3fe7d501ed23c986e17c7acb7b9009d0
+
+pkgname = trf
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..6862d81ae269
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,12 @@
+Tandem Repeats Finder License Terms
+
+The author of this software grants to any individual or organization
+the right to use and to make an unlimited number of copies of this
+software. You may not de-compile, disassemble, reverse engineer, or
+modify the software. This software cannot be sold, incorporated into
+commercial software or redistributed. The author of this software accepts
+no responsibility for damages resulting from the use of this software
+and makes no warranty or representation, either express or implied,
+including but not limited to, any implied warranty of merchantability
+or fitness for a particular purpose. This software is provided as is,
+and the user assumes all risks when using it.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..20ffac62e128
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Ben Booth <benwbooth@gmail.com>
+pkgname=trf
+pkgver=4.07b
+pkgrel=3
+pkgdesc="Tandem repeats finder: a program to analyze DNA sequences"
+arch=('i686' 'x86_64')
+url="http://tandem.bu.edu/trf/trf.html"
+license=('custom')
+source=( 'trf407b.linux64::http://tandem.bu.edu/cgi-bin/trf/trf.download.pl?fileselect=26'
+ 'trf407b.linux::http://tandem.bu.edu/cgi-bin/trf/trf.download.pl?fileselect=27'
+ 'LICENSE')
+md5sums=('26d83513f43f1456542123c6fe8eecf2'
+ '1b986c2e32d94be7f2357183f3154bce'
+ '3fe7d501ed23c986e17c7acb7b9009d0')
+package() {
+ install -d ${pkgdir}/usr/share/licenses/trf
+ install -D -m644 ${srcdir}/LICENSE ${pkgdir}/usr/share/licenses/trf
+
+ if test "$CARCH" == x86_64; then
+ install -D -m755 ${srcdir}/trf407b.linux64 ${pkgdir}/usr/bin/trf
+ elif test "$CARCH" == i686; then
+ install -D -m755 ${srcdir}/trf407b.linux ${pkgdir}/usr/bin/trf
+ fi
+}