summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Golatofski2020-01-12 16:17:48 +0100
committerFelix Golatofski2020-01-12 16:17:48 +0100
commit7672b7488101e107b58c54377fb85dda0af06859 (patch)
tree369e764f5ca7af50f85f138b852ce1bcb9a548e9
downloadaur-7672b7488101e107b58c54377fb85dda0af06859.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b966759b5189
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = triehash
+ pkgdesc = Generator for order-preserving minimal perfect hash functions in C
+ pkgver = 0.3
+ pkgrel = 1
+ url = https://github.com/julian-klode/triehash
+ arch = any
+ groups =
+ license = MIT
+ depends = perl
+ options = !strip
+ options = !emptydirs
+ source = http://archive.ubuntu.com/ubuntu/pool/universe/t/triehash/triehash_0.3-2_all.deb
+ sha512sums = 7fb1d24d93c944873cf37785ee59c15f946017f9fa9eeaec92ca23b1d08a8f6fbd0ee1d3b7f81066d499e9cf2dbdeaa45d859f9e7d79a61dba577239f0d3e50b
+
+pkgname = triehash
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6337d4774aa8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: TheGoliath
+# Contributor: TheGoliath
+pkgname=triehash
+pkgver=0.3
+pkgrel=1
+pkgdesc="Generator for order-preserving minimal perfect hash functions in C"
+arch=('any')
+url="https://github.com/julian-klode/triehash"
+license=('MIT')
+groups=('')
+depends=('perl')
+options=('!strip' '!emptydirs')
+source=("http://archive.ubuntu.com/ubuntu/pool/universe/t/triehash/triehash_0.3-2_all.deb")
+sha512sums=('7fb1d24d93c944873cf37785ee59c15f946017f9fa9eeaec92ca23b1d08a8f6fbd0ee1d3b7f81066d499e9cf2dbdeaa45d859f9e7d79a61dba577239f0d3e50b')
+
+package(){
+
+ # Extract package data
+ tar xf data.tar.xz -C "${pkgdir}"
+
+}