summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJingbei Li2017-06-13 19:09:02 +0800
committerJingbei Li2017-06-13 19:09:02 +0800
commit14d6687109176c49dd26c27ceb7b059e3b56a88b (patch)
tree69445866e7addc292013bb8812d54a49b1ade2f1
parent969c9cf96a6ac94c0386d7fefcab7b729f8e0757 (diff)
downloadaur-14d6687109176c49dd26c27ceb7b059e3b56a88b.tar.gz
updated to 12.10.1
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD89
3 files changed, 50 insertions, 60 deletions
diff --git a/.SRCINFO b/.SRCINFO
index daed630338b5..1ce2e4a4c57a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,30 @@
+# Generated by mksrcinfo v8
+# Tue Jun 13 11:08:36 UTC 2017
pkgbase = trilinos
pkgdesc = An effort to develop algorithms and enabling technologies within an object-oriented software framework for the solution of large-scale, complex multi-physics engineering and scientific problems.
- pkgver = 12.8.1
+ pkgver = 12.10.1
pkgrel = 1
url = http://trilinos.org
arch = i686
arch = x86_64
license = LGPL3
- makedepends = python2
makedepends = python2-numpy
makedepends = swig
- makedepends = gcc
makedepends = gcc-fortran
- makedepends = openmpi
makedepends = perl
makedepends = blas
- makedepends = lapack
makedepends = cmake
+ makedepends = gtest
+ makedepends = doxygen
depends = lapack
depends = openmpi
depends = python2
depends = boost
- source = git+https://github.com/trilinos/Trilinos.git#tag=trilinos-release-12-8-1
- md5sums = SKIP
+ depends = netcdf
+ depends = libmatio
+ depends = libx11
+ source = https://github.com/trilinos/Trilinos/archive/trilinos-release-12-10-1.tar.gz
+ md5sums = 40f28628b63310f9bd17c26d9ebe32b1
pkgname = trilinos
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cbb871d25c2d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.sw*
+*/
+*.tar.gz
+*.pkg*
diff --git a/PKGBUILD b/PKGBUILD
index eeda4fa98bfa..603fc28c45d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,68 +1,51 @@
-# vim:set ts=2 sw=2 et:
-# Maintainer: simon.pintarelli@gmail.com
+# Maintainer: Jingbei Li <i@jingbei.li>
+# Contributor: Simon Pintarelli <simon.pintarelli@gmail.com>
# Contributor: Feng Wang <wanng.fenng@gmail.com>
+
pkgname=trilinos
-pkgver=12.8.1
+_gitname=Trilinos
+pkgver=12.10.1
pkgrel=1
pkgdesc="An effort to develop algorithms and enabling technologies within an object-oriented software framework for the solution of large-scale, complex multi-physics engineering and scientific problems."
arch=('i686' 'x86_64')
url="http://trilinos.org"
license=('LGPL3')
-depends=('lapack' 'openmpi' 'python2' 'boost')
-source=('git+https://github.com/trilinos/Trilinos.git#tag=trilinos-release-12-8-1')
-md5sums=('SKIP')
-makedepends=('python2' 'python2-numpy' 'swig' 'gcc' 'gcc-fortran' 'openmpi' 'perl' 'blas' 'lapack' 'cmake')
-
-
-build() {
-
- cd "$srcdir/Trilinos"
+depends=('lapack' 'openmpi' 'python2' 'boost' 'netcdf' 'libmatio' 'libx11')
+source=("https://github.com/trilinos/$_gitname/archive/trilinos-release-${pkgver//./-}.tar.gz")
+md5sums=('40f28628b63310f9bd17c26d9ebe32b1')
+makedepends=('python2-numpy' 'swig' 'gcc-fortran' 'perl' 'blas' 'cmake' 'gtest' 'doxygen')
- find ${srcdir}/Trilinos -path .git -prune -name "*" -type f -exec \
- sed -i 's#\(/usr/bin/env \|/usr/bin/\)python[2-3]*#\1python2#' {} \;
+prepare() {
+ mv $srcdir/$_gitname-trilinos-release-${pkgver//./-} $srcdir/$_gitname
- sed -i 's#SWIG_VERSION_CEILING 2.0.8#SWIG_VERSION_CEILING 3.0.10#' \
- ${srcdir}/Trilinos/packages/PyTrilinos/CMakeLists.txt
-
- [[ -e build ]] && rm -rf build
- mkdir build
- cd build
-
- cmake .. \
- -DTrilinos_ENABLE_ALL_OPTIONAL_PACKAGES:BOOL=ON \
- -DTrilinos_ENABLE_ALL_PACKAGES:BOOL=ON \
- -DTrilinos_ENABLE_INTREPID:BOOL=OFF \
- -DTrilinos_ENABLE_SEACAS:BOOL=OFF \
- -DTrilinos_ENABLE_Mesquite:BOOL=OFF \
- -DTrilinos_ENABLE_FEI:BOOL=OFF \
- -DTrilinos_ENABLE_Gtest:BOOL=OFF \
- -DTrilinos_ENABLE_Shards:BOOL=OFF \
- -DTrilinos_ENABLE_OpenMP:BOOL=OFF \
- -DTpetra_INST_OpenMP:BOOL=ON \
- -DTPL_ENABLE_gtest:BOOL=ON \
- -DTPL_ENABLE_MPI:BOOL=ON \
- -DTPL_ENABLE_Matio:BOOL=OFF \
- -DTPL_ENABLE_GLM:BOOL=OFF \
- -DTPL_ENABLE_NETCDF:BOOL=OFF \
- -DTPL_ENABLE_X11:BOOL=OFF \
- -DTrilinos_ENABLE_CXX11:BOOL=ON \
- -DTrilinos_ENALBE_PAMGEN:BOOL=OFF \
- -DTrilinos_ENABLE_PyTrilinos:BOOL=ON \
- -DPYTHON_EXECUTABLE:PATH=/usr/bin/python2 \
- -DCMAKE_INSTALL_PREFIX:PATH=/usr \
- -DBUILD_SHARED_LIBS:BOOL=ON \
- -DCMAKE_BUILD_TYPE=Release \
- $EXTRA_ARGS
-
- make
+ find ${srcdir}/$_gitname -name "*.py" -exec \
+ sed -i '1s#\(/usr/bin/env \|/usr/bin/\)python[2-3]*#\1python2#' {} \;
+}
+build() {
+ cd $srcdir/$_gitname
+ mkdir build
+ cd build
+ cmake .. \
+ -DTrilinos_ENABLE_ALL_OPTIONAL_PACKAGES:BOOL=ON \
+ -DTrilinos_ENABLE_ALL_PACKAGES:BOOL=ON \
+ -DTrilinos_ENABLE_Gtest:BOOL=OFF \
+ -DTrilinos_ENABLE_TESTS=OFF \
+ -DTPL_ENABLE_gtest:BOOL=ON \
+ -DTPL_ENABLE_MPI:BOOL=ON \
+ -DPYTHON_EXECUTABLE:PATH=/usr/bin/python2 \
+ -DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DBUILD_SHARED_LIBS:BOOL=ON \
+ $EXTRA_ARGS
+ make
}
package() {
- cd $srcdir/Trilinos/build
- make install DESTDIR=$pkgdir
+ cd $srcdir/$_gitname/build
+ make install DESTDIR=$pkgdir
- # mkdir -p "${pkgdir}/etc/profile.d"
- # echo "export TRILINOS_DIR=/usr" > "${pkgdir}/etc/profile.d/trilinos.sh"
- # chmod +x "${pkgdir}/etc/profile.d/trilinos.sh"
+ #mkdir -p "${pkgdir}/etc/profile.d"
+ #echo "export TRILINOS_DIR=/usr" > "${pkgdir}/etc/profile.d/trilinos.sh"
+ #chmod +x "${pkgdir}/etc/profile.d/trilinos.sh"
}