summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Diehl2019-05-20 17:19:15 +0200
committerMartin Diehl2019-05-20 17:19:15 +0200
commitb0d8156858251481d6c1c781d1b0b430d339dbcf (patch)
tree62ce8fe576698d5f9d2866e474da49cbb7c0eaec
parentb6d1745af60686ac03e8aeceee072f2257bd7ed8 (diff)
downloadaur-b0d8156858251481d6c1c781d1b0b430d339dbcf.tar.gz
new version is out
I could not get pyTrilinos and tests to work. The problems do not seem to be related to Arch linux directly, probably they are simply incompatible with new versions of GCC etc.
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7a603071ea28..ac07025f9a09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,22 @@
+# Contributor: Martin Diehl <m.diehl@mpie.de>
# Contributor: Alad Wenter <alad@archlinux.org>
# Contributor: Jingbei Li <i@jingbei.li>
# Contributor: Simon Pintarelli <simon.pintarelli@gmail.com>
# Contributor: Feng Wang <wanng.fenng@gmail.com>
pkgname=trilinos
-pkgver=12.12.1
+pkgver=12.14.1
_pkgver=${pkgver//./-}
-pkgrel=4
+pkgrel=1
pkgdesc="algorithms for the solution of large-scale scientific problems"
arch=('x86_64')
url="http://trilinos.org"
license=('LGPL3')
-depends=('lapack' 'openmpi' 'python2' 'boost' 'netcdf' 'libmatio' 'libx11')
+depends=('lapack' 'python2' 'boost' 'netcdf' 'libmatio' 'libx11' 'hdf5-openmpi')
makedepends=('python2-numpy' 'swig' 'gcc-fortran' 'perl' 'blas' 'cmake'
'gtest' 'doxygen')
checkdepends=('cmake')
source=("https://github.com/trilinos/Trilinos/archive/trilinos-release-$_pkgver.tar.gz")
-sha256sums=('5474c5329c6309224a7e1726cf6f0d855025b2042959e4e2be2748bd6bb49e18')
+sha256sums=('52a4406cca2241f5eea8e166c2950471dd9478ad6741cbb2a7fc8225814616f0')
prepare() {
# https://github.com/trilinos/Trilinos/issues/862#issuecomment-365852261
@@ -30,10 +31,12 @@ build() {
cmake .. -DTrilinos_ENABLE_ALL_OPTIONAL_PACKAGES:BOOL=ON \
-DTrilinos_ENABLE_ALL_PACKAGES:BOOL=ON \
+ -DTrilinos_ENABLE_PyTrilinos:BOOL=OFF \
-DTrilinos_ENABLE_Gtest:BOOL=ON \
- -DTrilinos_ENABLE_TESTS=ON \
+ -DTrilinos_ENABLE_TESTS=OFF \
-DTPL_ENABLE_gtest:BOOL=ON \
-DTPL_ENABLE_MPI:BOOL=ON \
+ -DTPL_ENABLE_HDF5:BOOL=ON \
-DPYTHON_EXECUTABLE:PATH=/usr/bin/python2 \
-DCMAKE_INSTALL_PREFIX:PATH=/usr \
-DBUILD_SHARED_LIBS:BOOL=ON