summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlad Wenter2019-03-18 03:48:38 +0100
committerAlad Wenter2019-03-18 03:48:38 +0100
commitb6d1745af60686ac03e8aeceee072f2257bd7ed8 (patch)
treed1fa95536d4f698d3d2d6220657082c6d7bb3114
parent6329dc6a95ac2cf9efc01892c5156ee817aec7e4 (diff)
downloadaur-b6d1745af60686ac03e8aeceee072f2257bd7ed8.tar.gz
import changes from community
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD70
2 files changed, 39 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 90be6b0f1c4c..5fbf77f9dcfe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = trilinos
- pkgdesc = An effort to develop algorithms and enabling technologies within an object-oriented software framework for the solution of large-scale, complex multi-physics engineering and scientific problems.
+ pkgdesc = algorithms for the solution of large-scale scientific problems
pkgver = 12.12.1
- pkgrel = 2
+ pkgrel = 4
url = http://trilinos.org
- arch = i686
arch = x86_64
license = LGPL3
+ checkdepends = cmake
makedepends = python2-numpy
makedepends = swig
makedepends = gcc-fortran
@@ -22,7 +22,7 @@ pkgbase = trilinos
depends = libmatio
depends = libx11
source = https://github.com/trilinos/Trilinos/archive/trilinos-release-12-12-1.tar.gz
- md5sums = ecd4606fa332212433c98bf950a69cc7
+ sha256sums = 5474c5329c6309224a7e1726cf6f0d855025b2042959e4e2be2748bd6bb49e18
pkgname = trilinos
diff --git a/PKGBUILD b/PKGBUILD
index 29e43aed36ac..7a603071ea28 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,51 @@
-# Maintainer: Jingbei Li <i@jingbei.li>
+# Contributor: Alad Wenter <alad@archlinux.org>
+# Contributor: Jingbei Li <i@jingbei.li>
# Contributor: Simon Pintarelli <simon.pintarelli@gmail.com>
# Contributor: Feng Wang <wanng.fenng@gmail.com>
-
pkgname=trilinos
-_gitname=Trilinos
pkgver=12.12.1
-pkgrel=2
-pkgdesc="An effort to develop algorithms and enabling technologies within an object-oriented software framework for the solution of large-scale, complex multi-physics engineering and scientific problems."
-arch=('i686' 'x86_64')
+_pkgver=${pkgver//./-}
+pkgrel=4
+pkgdesc="algorithms for the solution of large-scale scientific problems"
+arch=('x86_64')
url="http://trilinos.org"
license=('LGPL3')
depends=('lapack' 'openmpi' 'python2' 'boost' 'netcdf' 'libmatio' 'libx11')
-source=("https://github.com/trilinos/$_gitname/archive/trilinos-release-${pkgver//./-}.tar.gz")
-md5sums=('ecd4606fa332212433c98bf950a69cc7')
-makedepends=('python2-numpy' 'swig' 'gcc-fortran' 'perl' 'blas' 'cmake' 'gtest' 'doxygen')
+makedepends=('python2-numpy' 'swig' 'gcc-fortran' 'perl' 'blas' 'cmake'
+ 'gtest' 'doxygen')
+checkdepends=('cmake')
+source=("https://github.com/trilinos/Trilinos/archive/trilinos-release-$_pkgver.tar.gz")
+sha256sums=('5474c5329c6309224a7e1726cf6f0d855025b2042959e4e2be2748bd6bb49e18')
prepare() {
- mv $srcdir/$_gitname-trilinos-release-${pkgver//./-} $srcdir/$_gitname
-
- find ${srcdir}/$_gitname -name "*.py" -exec \
- sed -i '1s#\(/usr/bin/env \|/usr/bin/\)python[2-3]*#\1python2#' {} \;
+ # https://github.com/trilinos/Trilinos/issues/862#issuecomment-365852261
+ find Trilinos-trilinos-release-"$_pkgver" -name "*.py" -exec \
+ sed -i '1s#\(/usr/bin/env \|/usr/bin/\)python[2-3]*#\1python2#' {} \;
}
build() {
- cd $srcdir/$_gitname
- mkdir -p build
- cd build
- cmake .. \
- -DTrilinos_ENABLE_ALL_OPTIONAL_PACKAGES:BOOL=ON \
- -DTrilinos_ENABLE_ALL_PACKAGES:BOOL=ON \
- -DTrilinos_ENABLE_Gtest:BOOL=OFF \
- -DTrilinos_ENABLE_TESTS=OFF \
- -DTPL_ENABLE_gtest:BOOL=ON \
- -DTPL_ENABLE_MPI:BOOL=ON \
- -DPYTHON_EXECUTABLE:PATH=/usr/bin/python2 \
- -DCMAKE_INSTALL_PREFIX:PATH=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DBUILD_SHARED_LIBS:BOOL=ON \
- $EXTRA_ARGS
- make
+ cd Trilinos-trilinos-release-"$_pkgver"
+ mkdir -p build
+ cd build
+
+ cmake .. -DTrilinos_ENABLE_ALL_OPTIONAL_PACKAGES:BOOL=ON \
+ -DTrilinos_ENABLE_ALL_PACKAGES:BOOL=ON \
+ -DTrilinos_ENABLE_Gtest:BOOL=ON \
+ -DTrilinos_ENABLE_TESTS=ON \
+ -DTPL_ENABLE_gtest:BOOL=ON \
+ -DTPL_ENABLE_MPI:BOOL=ON \
+ -DPYTHON_EXECUTABLE:PATH=/usr/bin/python2 \
+ -DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ -DBUILD_SHARED_LIBS:BOOL=ON
+ make VERBOSE=1
}
-package() {
- cd $srcdir/$_gitname/build
- make install DESTDIR=$pkgdir
+check() {
+ cd Trilinos-trilinos-release-"$_pkgver"/build
+ ctest
+}
- #mkdir -p "${pkgdir}/etc/profile.d"
- #echo "export TRILINOS_DIR=/usr" > "${pkgdir}/etc/profile.d/trilinos.sh"
- #chmod +x "${pkgdir}/etc/profile.d/trilinos.sh"
+package() {
+ cd Trilinos-trilinos-release-"$_pkgver"/build
+ make DESTDIR="$pkgdir" install
}