summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Diehl2020-06-05 07:09:37 +0200
committerMartin Diehl2020-06-05 07:09:37 +0200
commitbd500effd5532cfcd7138c5fae67791f5530e30d (patch)
tree759a8d41922605689a35ee23553a713f6e36d73b
parent422e7335ae403f32715a9b663037595913b40136 (diff)
downloadaur-bd500effd5532cfcd7138c5fae67791f5530e30d.tar.gz
compiles with GCC 10
Need to relax come correctnes checks for SEACAS (already fixed upstream)
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD9
-rw-r--r--Seacas.patch14
4 files changed, 24 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8cd7c17ff62b..defdea2af019 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = trilinos
pkgdesc = algorithms for the solution of large-scale scientific problems
pkgver = 12.18.1
- pkgrel = 2
+ pkgrel = 3
url = http://trilinos.org
arch = x86_64
license = LGPL3
@@ -22,8 +22,10 @@ pkgbase = trilinos
conflicts = gtest
source = https://github.com/trilinos/Trilinos/archive/trilinos-release-12-18-1.tar.gz
source = Makefile.kokkos.patch
+ source = Seacas.patch
sha256sums = 7d2e1a1a3e2d2ce78bb248c63411fed5007c827b87cadee3d13c1a45c09a89cf
sha256sums = 64130011dd70f3be1133c0943be458a7d4f6fa799e6bd47a6294300ced6d827a
+ sha256sums = 0e2f10b7ba4f7349eaef6bff111cda6de6d216ab417e24bf0b342711117a7374
pkgname = trilinos
diff --git a/.gitignore b/.gitignore
index b5bc2aa573e1..44f27c04b1e5 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,3 @@
pkg
src
-*.tar.xz
-*.tar.gz
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
index b6868297c218..ce7464f5d36d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=trilinos
pkgver=12.18.1
_pkgver=${pkgver//./-}
-pkgrel=2
+pkgrel=3
pkgdesc="algorithms for the solution of large-scale scientific problems"
arch=('x86_64')
url="http://trilinos.org"
@@ -16,13 +16,16 @@ makedepends=('gcc-fortran' 'perl' 'blas' 'cmake' 'doxygen' 'bc')
conflicts=('gtest')
checkdepends=('cmake')
source=("https://github.com/trilinos/Trilinos/archive/trilinos-release-$_pkgver.tar.gz"
- "Makefile.kokkos.patch")
+ "Makefile.kokkos.patch"
+ "Seacas.patch")
sha256sums=('7d2e1a1a3e2d2ce78bb248c63411fed5007c827b87cadee3d13c1a45c09a89cf'
- '64130011dd70f3be1133c0943be458a7d4f6fa799e6bd47a6294300ced6d827a')
+ '64130011dd70f3be1133c0943be458a7d4f6fa799e6bd47a6294300ced6d827a'
+ '0e2f10b7ba4f7349eaef6bff111cda6de6d216ab417e24bf0b342711117a7374')
prepare() {
cd Trilinos-trilinos-release-12-18-1
patch --forward --strip=1 --input="${srcdir}/Makefile.kokkos.patch"
+ patch --forward --strip=1 --input="${srcdir}/Seacas.patch"
}
diff --git a/Seacas.patch b/Seacas.patch
new file mode 100644
index 000000000000..7a563fa95828
--- /dev/null
+++ b/Seacas.patch
@@ -0,0 +1,14 @@
+diff --unified --recursive --text Trilinos-trilinos-release-12-18-1.orig/packages/seacas/CMakeLists.txt Trilinos-trilinos-release-12-18-1.new/packages/seacas/CMakeLists.txt
+--- Trilinos-trilinos-release-12-18-1.orig/packages/seacas/CMakeLists.txt 2020-06-05 00:42:08.312487932 +0200
++++ Trilinos-trilinos-release-12-18-1.new/packages/seacas/CMakeLists.txt 2020-06-05 00:43:42.822501254 +0200
+@@ -85,7 +85,10 @@
+ )
+ SET(CMAKE_Fortran_LINK_EXECUTABLE empty)
+ ENDIF()
++ELSE()
++ set (CMAKE_Fortran_FLAGS "${CMAKE_Fortran_FLAGS} -fallow-argument-mismatch -fallow-invalid-boz")
+ ENDIF()
++set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fcommon")
+
+ ASSERT_DEFINED(TPL_ENABLE_Pthread)
+ IF (SEACASExodus_ENABLE_THREADSAFE AND NOT TPL_ENABLE_Pthread)