summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwangjiezhe2019-12-04 20:53:58 +0800
committerwangjiezhe2019-12-04 20:53:58 +0800
commitb6f60718b40270e89fed5896a3445931ca4f265b (patch)
treecae5e4b7020e489eb1def7dedbdff38674574751
parent31581816637d365d4190e533e44b78b53969a4e3 (diff)
downloadaur-b6f60718b40270e89fed5896a3445931ca4f265b.tar.gz
Add ccache as makedepends
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0d436b4cb2b..eedd5d794b54 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Tue Dec 19 03:33:09 UTC 2017
pkgbase = trilinos-git
- pkgdesc = An effort to develop algorithms and enabling technologies within an object-oriented software framework for the solution of large-scale, complex multi-physics engineering and scientific problems.
- pkgver = 12.12.0.gd3b096f4f1
+ pkgdesc = Algorithms for the solution of large-scale, complex multi-physics engineering and scientific problems.
+ pkgver = 12.12.11145.g7a152b4248
pkgrel = 1
url = https://github.com/trilinos/Trilinos
arch = x86_64
@@ -20,6 +18,7 @@ pkgbase = trilinos-git
makedepends = cmake
makedepends = libmatio
makedepends = netcdf
+ makedepends = ccache
depends = lapack
depends = openmpi
depends = python2
diff --git a/PKGBUILD b/PKGBUILD
index fd8e9b42fc12..865d61fff242 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,9 +19,9 @@
pkgname=trilinos-git
_pkgname=Trilinos
-pkgver=12.12.0.gd3b096f4f1
+pkgver=12.12.11145.g7a152b4248
pkgrel=1
-pkgdesc="An effort to develop algorithms and enabling technologies within an object-oriented software framework for the solution of large-scale, complex multi-physics engineering and scientific problems."
+pkgdesc="Algorithms for the solution of large-scale, complex multi-physics engineering and scientific problems."
arch=('x86_64')
url="https://github.com/trilinos/Trilinos"
license=('LGPL3')
@@ -29,7 +29,7 @@ depends=('lapack' 'openmpi' 'python2' 'boost')
provides=('trilinos')
conflicts=('trilinos')
source=(git+${url}.git)
-makedepends=('git' 'python2' 'python2-numpy' 'swig' 'gcc' 'gcc-fortran' 'openmpi' 'perl' 'blas' 'lapack' 'cmake' 'libmatio' 'netcdf')
+makedepends=('git' 'python2' 'python2-numpy' 'swig' 'gcc' 'gcc-fortran' 'openmpi' 'perl' 'blas' 'lapack' 'cmake' 'libmatio' 'netcdf' 'ccache')
# gcc-fortran gcc-fortran-multilib
md5sums=('SKIP')
options=('ccache')
@@ -62,7 +62,7 @@ build() {
-DTrilinos_ENABLE_PyTrilinos:BOOL=ON \
-DPyTrilinos_DOCSTRINGS:BOOL=OFF \
-DPYTHON_EXECUTABLE:PATH=/usr/bin/python2 \
- -DCMAKE_INSTALL_PREFIX:PATH=/opt/trilinos \
+ -DCMAKE_INSTALL_PREFIX:PATH=/usr \
-DTPL_ENABLE_Netcdf=ON \
-DTPL_ENABLE_QT=OFF \
-DTPL_ENABLE_GLM=OFF \
@@ -72,11 +72,12 @@ build() {
make
}
+check() {
+ cd $srcdir/${_pkgname}/build
+ ctest
+}
+
package() {
cd $srcdir/${_pkgname}/build
make install DESTDIR=$pkgdir
-
- mkdir -p "${pkgdir}/etc/profile.d"
- echo "export TRILINOS_DIR=/opt/trilinos" > "${pkgdir}/etc/profile.d/trilinos.sh"
- chmod +x "${pkgdir}/etc/profile.d/trilinos.sh"
}