summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBryce Kabat2020-07-12 12:49:48 -0500
committerBryce Kabat2020-07-12 12:49:48 -0500
commita6b9465bca70c7fe38a322ac5afbc210260fd06c (patch)
tree894ab2ccae8a58c8608ed21b786da3e8a2c237c1
parenta21e7e9ef89a80072e5d532068200c21a5fb3a8f (diff)
downloadaur-a6b9465bca70c7fe38a322ac5afbc210260fd06c.tar.gz
Modernized PKGBUILD and improved compliance with namcap.
-rwxr-xr-x.SRCINFO7
-rwxr-xr-xPKGBUILD23
2 files changed, 13 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 28c3f2499290..80b4f00272e9 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,12 @@
pkgbase = trilium-bin
pkgdesc = A hierarchical note taking application built on modern technologies.
pkgver = 0.43.2
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/zadam/trilium
arch = x86_64
- license = AGPL
- depends = python
- depends = make
+ license = AGPL3
depends = libxss
depends = nss
- depends = lib32-gcc-libs
depends = gtk3
source = https://github.com/zadam/trilium/releases/download/v0.43.2/trilium-linux-x64-0.43.2.tar.xz
sha512sums = a3cf0d5da172b27f4a1a275bdc8f4d3537e0a0448effa43319c3b93239cdaa3f64cb9d5bc16f20affad392816ec2c3854e0a59bb74ab7b2b16c39ea0b248158d
diff --git a/PKGBUILD b/PKGBUILD
index 691dda9434af..2dee15752883 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,28 @@
# Maintainer: Bryce Kabat <brycekabat@onyxazryn.com>
pkgname="trilium-bin"
pkgver=0.43.2
-pkgrel=2
+pkgrel=3
pkgdesc="A hierarchical note taking application built on modern technologies."
-depends=('python' 'make' 'libxss' 'nss' 'lib32-gcc-libs' 'gtk3')
+depends=('libxss' 'nss' 'gtk3')
arch=('x86_64')
url="https://github.com/zadam/trilium"
-license=('AGPL')
+license=('AGPL3')
source=("https://github.com/zadam/trilium/releases/download/v$pkgver/trilium-linux-x64-$pkgver.tar.xz")
sha512sums=('a3cf0d5da172b27f4a1a275bdc8f4d3537e0a0448effa43319c3b93239cdaa3f64cb9d5bc16f20affad392816ec2c3854e0a59bb74ab7b2b16c39ea0b248158d')
package()
{
export destdir="$pkgdir/"
- #Make folders for extraction
- mkdir -p "$pkgdir/opt/trilium"
+ # Make folders for extraction
+ mkdir -p "$pkgdir/opt/$pkgname"
mkdir -p "$pkgdir/usr/bin"
mkdir -p "$pkgdir/usr/share/applications"
- #Move main files
- mv trilium-linux-x64/* "$pkgdir/opt/trilium"
- chmod -R 0755 "$pkgdir/opt/trilium"
- #Write command and make executable
+ # Move main files
+ mv trilium-linux-x64/* "$pkgdir/opt/$pkgname"
+ # Write command and make executable
echo -e "#!/bin/sh
-/opt/trilium/trilium" > "$pkgdir/usr/bin/trilium"
- chmod +x "$pkgdir/usr/bin/trilium"
- #Create .desktop file
+/opt/$pkgname/trilium" > "$pkgdir/usr/bin/trilium"
+ # Create .desktop file
echo -e "[Desktop Entry]
Name=Trilium
GenericName=Note Taking Application
@@ -35,4 +33,5 @@ Terminal=false
Type=Application
Categories=Office
StartupWMClass=trilium notes" > "$pkgdir/usr/share/applications/trilium.desktop"
+ chmod -R 0755 "$pkgdir"
}