summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBryce Kabat2022-05-02 20:43:53 -0500
committerBryce Kabat2022-05-02 20:43:53 -0500
commitfa738674854811d4a05325a1202d3683b87dbb88 (patch)
tree30bde6761c25ef630d692a19a64126e1656d7af3
parentf7e884ead5f190331034a43eeab89bc477274c0d (diff)
downloadaur-fa738674854811d4a05325a1202d3683b87dbb88.tar.gz
Updated to 0.51.2
-rwxr-xr-x.SRCINFO6
-rwxr-xr-x.gitignore4
-rwxr-xr-xPKGBUILD4
-rw-r--r--script.sh12
4 files changed, 17 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 569cae3e5ea1..cd39d4e88642 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = trilium-bin
pkgdesc = A hierarchical note taking application built on modern technologies.
- pkgver = 0.50.3
+ pkgver = 0.51.2
pkgrel = 1
url = https://github.com/zadam/trilium
arch = x86_64
@@ -8,7 +8,7 @@ pkgbase = trilium-bin
depends = libxss
depends = nss
depends = gtk3
- source = https://github.com/zadam/trilium/releases/download/v0.50.3/trilium-linux-x64-0.50.3.tar.xz
- sha512sums = 218cc68ce0410f17d1a8c2192bbafd588a4d1ba6d1a3dbfa10c851d7eb558063072cdc51b1e26f1d3bf9a08bafe484679d7466b5f1fd584f038c9529d3d8b30f
+ source = https://github.com/zadam/trilium/releases/download/v0.51.2/trilium-linux-x64-0.51.2.tar.xz
+ sha512sums = fa37cc9d624725c9696e2570945fee512242b4f3f90e792350c88924b3359cf2eee64b6b742353137424dd5607cfae43ac6059e4f9c7b73105054a7ed4142dd3
pkgname = trilium-bin
diff --git a/.gitignore b/.gitignore
deleted file mode 100755
index d5c0597102fd..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,4 +0,0 @@
-script.sh
-trilium-*
-pkg/
-src/
diff --git a/PKGBUILD b/PKGBUILD
index 9e6db14c0d9d..094d4d7db4e7 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Bryce Kabat <brycekabat@onyxazryn.com>
pkgname="trilium-bin"
-pkgver=0.50.3
+pkgver=0.51.2
pkgrel=1
pkgdesc="A hierarchical note taking application built on modern technologies."
depends=('libxss' 'nss' 'gtk3')
@@ -8,7 +8,7 @@ arch=('x86_64')
url="https://github.com/zadam/trilium"
license=('AGPL3')
source=("https://github.com/zadam/trilium/releases/download/v$pkgver/trilium-linux-x64-$pkgver.tar.xz")
-sha512sums=('218cc68ce0410f17d1a8c2192bbafd588a4d1ba6d1a3dbfa10c851d7eb558063072cdc51b1e26f1d3bf9a08bafe484679d7466b5f1fd584f038c9529d3d8b30f')
+sha512sums=('fa37cc9d624725c9696e2570945fee512242b4f3f90e792350c88924b3359cf2eee64b6b742353137424dd5607cfae43ac6059e4f9c7b73105054a7ed4142dd3')
package()
{
diff --git a/script.sh b/script.sh
new file mode 100644
index 000000000000..6d20ff6237cd
--- /dev/null
+++ b/script.sh
@@ -0,0 +1,12 @@
+#!/bin/bash
+nano PKGBUILD
+updpkgsums
+makepkg --printsrcinfo > .SRCINFO
+makepkg
+namcap *.pkg.*
+paru -U *.pkg.*
+rm -rf trilium-* pkg/ src/
+git add .
+git commit
+git push
+