summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNriver2023-01-09 17:31:45 +0800
committerNriver2023-01-09 17:31:45 +0800
commitaf34d879bfd17b2b6484df7895c75663068e96e9 (patch)
tree5f6e4f07c6fa28a2f640689ac448b88ae480dd3a
parent0b690ed16163231596ea21ac3b8166f7627ed112 (diff)
downloadaur-af34d879bfd17b2b6484df7895c75663068e96e9.tar.gz
fix executables, add ignore file
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD10
-rwxr-xr-xrebuild.sh3
-rw-r--r--trilium-cn.sh2
5 files changed, 15 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4196404b1158..88fb2016d4ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = trilium-cn
- pkgdesc = Trilium Notes 中文版
+ pkgdesc = Trilium Notes Chinese version
pkgver = 0.57.5_20221216
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/Nriver/trilium-translation
arch = x86_64
license = AGPL3
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ac8ed4560b84
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/*
+src/*
+trilium-cn-linux-x64.zip \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index dba2a1cde4de..260fd5c99646 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Nriver <6752679+Nriver@users.noreply.github.com>
pkgname="trilium-cn"
pkgver=0.57.5_20221216
-pkgrel=4
-pkgdesc="Trilium Notes 中文版"
+pkgrel=5
+pkgdesc="Trilium Notes Chinese version"
arch=('x86_64')
url="https://github.com/Nriver/trilium-translation"
license=('AGPL3')
@@ -17,8 +17,10 @@ package() {
mkdir -p "$pkgdir/usr/share/applications"
# Move main files
mv trilium-linux-x64/* "$pkgdir/opt/$pkgname"
+
+ echo $PWD
# Create command
- install -vDm755 "${srcdir}/trilium-cn.sh" $pkgdir/usr/bin/trilium-cn
+ install -vDm755 ../trilium-cn.sh $pkgdir/usr/bin/trilium-cn
# Create .desktop file
- install -vDm755 "${srcdir}/trilium-cn.desktop" "$pkgdir/usr/share/applications/trilium-cn.desktop"
+ install -vDm755 ../trilium-cn.desktop "$pkgdir/usr/share/applications/trilium-cn.desktop"
}
diff --git a/rebuild.sh b/rebuild.sh
index 9eb2cb35d758..43a594946634 100755
--- a/rebuild.sh
+++ b/rebuild.sh
@@ -1 +1,4 @@
+rm -rf src
+rm -rf pkg
+rm *.pkg.tar.zst
makepkg --printsrcinfo > .SRCINFO \ No newline at end of file
diff --git a/trilium-cn.sh b/trilium-cn.sh
index 723ad3c76c47..f24881f70d44 100644
--- a/trilium-cn.sh
+++ b/trilium-cn.sh
@@ -1,3 +1,3 @@
#!/bin/sh
-cd /opt/opt/trilium-cn/
+cd /opt/trilium-cn/
./trilium \ No newline at end of file