summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHanFox2015-07-11 15:33:58 +0100
committerHanFox2015-07-11 15:33:58 +0100
commit5670eaf1cbef98c0669f29e04353ff2920f036da (patch)
tree66db63d248bb44c046738688541ab47363a8918e
downloadaur-5670eaf1cbef98c0669f29e04353ff2920f036da.tar.gz
Initial import - update to 2.0.0.5 and add libappindicator-gtk3 optdep
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD24
-rw-r--r--trillian.install13
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1581ff20b5cf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = trillian
+ pkgdesc = A commercial, multi-protocol and cross-platform IM client
+ pkgver = 2.0.0.5
+ pkgrel = 1
+ url = https://www.trillian.im
+ install = trillian.install
+ arch = i686
+ arch = x86_64
+ license = Proprietary
+ depends = gtkmm3
+ depends = libzip
+ depends = openssl
+ depends = webkitgtk
+ depends = libnotify
+ depends = libpulse
+ depends = libxss
+ depends = librsvg
+ optdepends = libappindicator-gtk3: tray icon support
+ source_i686 = https://www.trillian.im/get/linux/2.0/?deb=32
+ md5sums_i686 = a35ecdf0da66c240d0b604d7fa76cc5b
+ source_x86_64 = https://www.trillian.im/get/linux/2.0/?deb=64
+ md5sums_x86_64 = 47b01ab8c2dd5e3b1ae51a19492f7a4c
+
+pkgname = trillian
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..53ccbe8622cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Original Maintainer: mariusn <marius softpedia com>
+# Maintainer: HanFox <hanfox dot co dot uk>
+# Contributor: Doug Newgard <scimmia22 at outlook dot com>
+
+pkgname=trillian
+pkgver=2.0.0.5
+pkgrel=1
+pkgdesc="A commercial, multi-protocol and cross-platform IM client"
+arch=('i686' 'x86_64')
+url="https://www.trillian.im"
+license=('Proprietary')
+depends=('gtkmm3' 'libzip' 'openssl' 'webkitgtk' 'libnotify' 'libpulse' 'libxss' 'librsvg')
+optdepends=('libappindicator-gtk3: tray icon support')
+install='trillian.install'
+
+source_x86_64=("https://www.trillian.im/get/linux/2.0/?deb=64")
+source_i686=("https://www.trillian.im/get/linux/2.0/?deb=32")
+md5sums_x86_64=('47b01ab8c2dd5e3b1ae51a19492f7a4c')
+md5sums_i686=('a35ecdf0da66c240d0b604d7fa76cc5b')
+
+
+package() {
+ tar xzvf "$srcdir/data.tar.gz" -C "$pkgdir/"
+} \ No newline at end of file
diff --git a/trillian.install b/trillian.install
new file mode 100644
index 000000000000..c50ebf80f6da
--- /dev/null
+++ b/trillian.install
@@ -0,0 +1,13 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+