summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-12-03 07:51:49 +1300
committercaltlgin2020-12-03 07:51:49 +1300
commit88b66f6714270e3d3d8452ed92426ce7c0b4c902 (patch)
treed8d96a53cac5e0b1502b822c44b1573de1e048fd
parent542c1697b5fb4849e419b7ebc4609a0bfa44389f (diff)
downloadaur-trimage-git.tar.gz
Python 3.9 rebuild
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD8
3 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bdf3d8250394..63e599f59742 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
pkgbase = trimage-git
pkgdesc = Tool for optimizing PNG and JPG files
pkgver = 1.0.6.r12.gc21089f
- pkgrel = 1
+ pkgrel = 2
url = https://trimage.org
- arch = x86_64
+ arch = any
license = MIT
makedepends = git
makedepends = python-setuptools
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index a1fa3786cb52..a023e4593902 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,9 @@
_pkgname='trimage'
pkgname="${_pkgname}-git"
pkgver=1.0.6.r12.gc21089f
-pkgrel=1
+pkgrel=2
pkgdesc='Tool for optimizing PNG and JPG files'
-arch=('x86_64')
+arch=('any')
url='https://trimage.org'
_url_source='https://github.com/Kilian/Trimage'
license=('MIT')
@@ -29,8 +29,8 @@ build() {
package() {
cd "${_pkgname}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -Dm644 -t "${pkgdir}/usr/share/doc/${_pkgname}" 'README.md'
- install -Dm644 'COPYING' "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${_pkgname}"
+ install -Dvm644 'COPYING' "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
}
# vim: ts=2 sw=2 et: