summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn-Michael Mulesa2021-09-11 15:54:38 +1000
committerJohn-Michael Mulesa2021-09-11 15:54:38 +1000
commita1127d0766d4365337202a9097a1a28c82dc7b4f (patch)
tree6baa88a8aa739ebe1fe2dddf5fe580008c204bb0
downloadaur-a1127d0766d4365337202a9097a1a28c82dc7b4f.tar.gz
Initial commit.
-rw-r--r--.SRCINFO41
-rw-r--r--PKGBUILD49
-rw-r--r--trine2.desktop8
-rw-r--r--trine2.sh3
4 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..724b624daa18
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,41 @@
+pkgbase = trine2-gog
+ pkgdesc = GOG version of Trine Enchanted Edition
+ pkgver = 2.0.0.5
+ pkgrel = 1
+ url = https://www.gog.com/game/trine_2_complete_story
+ arch = i686
+ arch = x86_64
+ groups = games
+ license = custom
+ depends = xorg-xwininfo
+ depends = desktop-file-utils
+ optdepends = lib32-gtk-engine-murrine: Fixes the Gtk-WARNING error about « murrine »
+ optdepends = lib32-gtk-engines: Fixes the Gtk-WARNING about « adwaita »
+ source = gog_trine_2_complete_story_2.0.0.5.sh::gogdownloader://trine_2_complete_story/en3installer2
+ source = trine2.sh
+ source = trine2.desktop
+ sha256sums = 7a5d5b4a4bc9eee8a80d2975c61963e286c33fba41a115264d0f77aad9ea1408
+ sha256sums = 66ad2ebf559e95f1891a1e2afd7b435e30726f950e84109703a407f93befbfe6
+ sha256sums = d35f9826cad06a78e9cdaa83f30c5abd20f1aca414792cf6b1acc950e139dbd2
+ depends_i686 = glu
+ depends_i686 = libxxf86vm
+ depends_i686 = openal
+ depends_i686 = libdrm
+ depends_i686 = libpng12
+ depends_i686 = libogg
+ depends_i686 = libvorbis
+ depends_i686 = freetype2
+ depends_i686 = libx11
+ depends_x86_64 = lib32-glu
+ depends_x86_64 = lib32-libxxf86vm
+ depends_x86_64 = lib32-openal
+ depends_x86_64 = lib32-libx11
+ depends_x86_64 = lib32-libdrm
+ depends_x86_64 = lib32-libvorbis
+ depends_x86_64 = lib32-freetype2
+ depends_x86_64 = lib32-libogg
+ depends_x86_64 = lib32-gtk2
+ depends_x86_64 = lib32-gdk-pixbuf2
+ depends_x86_64 = lib32-libpng12
+
+pkgname = trine2-gog
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7175c7db9a6e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: John-Michael Mulesa <jmulesa at gmail dot com>
+
+pkgname=trine2-gog
+_pkgname=trine2
+pkgver=2.0.0.5
+pkgrel=1
+pkgdesc="GOG version of Trine Enchanted Edition"
+arch=("i686" "x86_64")
+url="https://www.gog.com/game/trine_2_complete_story"
+license=("custom")
+groups=("games")
+source=("gog_trine_2_complete_story_${pkgver}.sh::gogdownloader://trine_2_complete_story/en3installer2" "${_pkgname}.sh" "${_pkgname}.desktop")
+depends=('xorg-xwininfo' 'desktop-file-utils')
+depends_i686=('glu' 'libxxf86vm' 'openal' 'libdrm' 'libpng12' 'libogg' 'libvorbis' 'freetype2' 'libx11')
+depends_x86_64=('lib32-glu' 'lib32-libxxf86vm' 'lib32-openal' 'lib32-libx11'
+ 'lib32-libdrm' 'lib32-libvorbis' 'lib32-freetype2' 'lib32-libogg'
+ 'lib32-gtk2' 'lib32-gdk-pixbuf2' 'lib32-libpng12')
+optdepends=('lib32-gtk-engine-murrine: Fixes the Gtk-WARNING error about « murrine »'
+ 'lib32-gtk-engines: Fixes the Gtk-WARNING about « adwaita »')
+sha256sums=('7a5d5b4a4bc9eee8a80d2975c61963e286c33fba41a115264d0f77aad9ea1408'
+ '66ad2ebf559e95f1891a1e2afd7b435e30726f950e84109703a407f93befbfe6'
+ 'd35f9826cad06a78e9cdaa83f30c5abd20f1aca414792cf6b1acc950e139dbd2')
+
+# If you want to use lgogdownloader add the following to /etc/makepkg.conf
+# DLAGENTS+=('gogdownloader::/usr/bin/lgogdownloader --download-file=%u -o %o')
+DLAGENTS+=("gogdownloader::/usr/bin/echo Could not find gog installer file (%u). Manually download it to \"$(pwd)\", or set up a gogdownloader:// DLAGENT in /etc/makepkg.conf. See PKGBUILD for example.")
+
+package() {
+ # game files
+ mkdir -p "${pkgdir}/opt/${_pkgname}"
+ cp -r "${srcdir}/data/noarch/"* "${pkgdir}/opt/${_pkgname}/"
+
+ # launcher
+ chmod 755 "${pkgdir}/opt/${_pkgname}/start.sh"
+ install -Dm755 "${srcdir}/${_pkgname}.sh" "${pkgdir}/usr/bin/${_pkgname}"
+
+ # desktop environment integration
+ install -Dm644 \
+ "${srcdir}/data/noarch/support/icon.png" \
+ "${pkgdir}/usr/share/pixmaps/${_pkgname}.png"
+ install -Dm644 \
+ "${srcdir}/${_pkgname}.desktop" \
+ "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+
+ # license
+ install -Dm644 \
+ "${srcdir}/data/noarch/docs/End User License Agreement.txt" \
+ "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}
diff --git a/trine2.desktop b/trine2.desktop
new file mode 100644
index 000000000000..0d85b65f918d
--- /dev/null
+++ b/trine2.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Trine 2
+Comment=GOG version of Trine 2 Complete Story
+Exec=/usr/bin/trine2
+Icon=trine2
+Terminal=false
+Type=Application
+Categories=Game;
diff --git a/trine2.sh b/trine2.sh
new file mode 100644
index 000000000000..caad1ac6225a
--- /dev/null
+++ b/trine2.sh
@@ -0,0 +1,3 @@
+#!/bin/bash
+cd /opt/trine2
+./start.sh