summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorg Schlisio2016-07-05 17:28:04 +0200
committerGeorg Schlisio2016-07-05 17:28:04 +0200
commit304adb3c5dc05af92b178066dcd9351ca7cb36a0 (patch)
tree40ca389b9d0bf9c10bd32f8f81393bb96b0c9b8e
parente75989db2028335eda5addb6c6a297f00fe161c5 (diff)
downloadaur-304adb3c5dc05af92b178066dcd9351ca7cb36a0.tar.gz
fixed startet, added desktop file and logo. thanks to postblue for contributing
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD20
-rw-r--r--trine3.desktop10
3 files changed, 31 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 84b5c948a819..c6ce8aed6deb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,18 @@
pkgbase = trine3-hib
pkgdesc = action role-playing platform and puzzle video game. humblebundle version.
pkgver = 2015.12.01
- pkgrel = 1
+ pkgrel = 2
url = https://trine3.com
install = trine3.install
arch = x86_64
license = commercial
+ depends = xorg-xwininfo
source = hib://trine3_linux.zip
+ source = trine3.desktop
+ source = http://frozenbyte.com/presskit/trine_3/images/logo.png
md5sums = 28070d73b2291c30e31b5ef486b9f3ac
+ md5sums = 07c2c50dfa0a87e66076b13bfaf83730
+ md5sums = 1e36d51c0b6ddf8f283a46404796d85b
pkgname = trine3-hib
diff --git a/PKGBUILD b/PKGBUILD
index 604ae892cd23..7f768790adf2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,20 @@
# Maintainer: fordprefect <fordprefect@dukun.de>
pkgname=trine3-hib
pkgver=2015.12.01
-pkgrel=1
+pkgrel=2
pkgdesc="action role-playing platform and puzzle video game. humblebundle version."
url="https://trine3.com"
arch=('x86_64')
license=('commercial')
-depends=("")
+depends=("xorg-xwininfo")
install=trine3.install
-source=("hib://trine3_linux.zip")
+source=("hib://trine3_linux.zip"
+ "trine3.desktop"
+ "http://frozenbyte.com/presskit/trine_3/images/logo.png")
# there is a patch downloadable, but it is already included in the game
-md5sums=('28070d73b2291c30e31b5ef486b9f3ac')
+md5sums=('28070d73b2291c30e31b5ef486b9f3ac'
+ '07c2c50dfa0a87e66076b13bfaf83730'
+ '1e36d51c0b6ddf8f283a46404796d85b')
PKGEXT=".pkg.tar"
DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Manually download it to \"$(pwd)\", or set up a hib:// DLAGENT in /etc/makepkg.conf."; exit 1')
@@ -19,12 +23,18 @@ package() {
mkdir -p "${pkgdir}/opt/trine3"
mv "${srcdir}/linux/"* "${pkgdir}/opt/trine3"
+ # install desktop file and icon
+ install -Dm644 "$srcdir/trine3.desktop" "$pkgdir/usr/share/applications/trine3.desktop"
+ mkdir -p "$pkgdir/usr/share/pixmaps"
+ convert -resize 48x48 "$srcdir/logo.png" "$pkgdir/usr/share/pixmaps/trine3_48.png"
+ convert -resize 64x64 "$srcdir/logo.png" "$pkgdir/usr/share/pixmaps/trine3_64.png"
+
# starter script
mkdir -p "${pkgdir}/usr/bin"
cat >> "${pkgdir}/usr/bin/trine3" << \here
#!/bin/sh
cd /opt/trine3
-trine3.sh
+./trine3.sh
here
chmod a+x "${pkgdir}/usr/bin/trine3"
}
diff --git a/trine3.desktop b/trine3.desktop
new file mode 100644
index 000000000000..d530cc5bdbd9
--- /dev/null
+++ b/trine3.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=Trine 3
+Comment=action role-playing platform and puzzle video game
+Path=/usr/bin
+Exec=trine3
+Icon=
+Terminal=false
+Categories=Game;