summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Anderson2019-03-27 09:51:20 +0000
committerAndrew Anderson2019-03-27 09:51:20 +0000
commit90c29d553c01b1fe685dd9c5d85e66bd0442cf0e (patch)
tree15eb7dfa2bf3e9ef0b765170245cfe643c13c352
parent18111e38146910a00fffb95706a2c653bed3899e (diff)
downloadaur-90c29d553c01b1fe685dd9c5d85e66bd0442cf0e.tar.gz
Enable OpenMP
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d8a91cb090c..025bbc296941 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = trinnity-caffe-git
pkgdesc = Caffe 1.0 with triNNity extensions
pkgver = 1.0
- pkgrel = 13
+ pkgrel = 14
url = https://bitbucket.org/STG-TCD/trinnity-caffe
arch = x86_64
license = BSD
@@ -30,9 +30,12 @@ pkgbase = trinnity-caffe-git
depends = python-scikit-image
depends = opencv>=4.0.0
depends = gtk3
+ depends = openmp
optdepends = openblas: OpenBLAS for backend linear algebra ops,
optdepends = cblas: Use CBLAS for backend linear algebra ops
provides = caffe
+ conflicts = trinnity-caffe-cuda-git
+ conflicts = trinnity-caffe-cudnn-git
source = trinnity-caffe::git+https://bitbucket.org/STG-TCD/trinnity-caffe.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index d8fe3247b469..4224d5179f8d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=trinnity-caffe-git
_srcname=trinnity-caffe
pkgver=1.0
-pkgrel=13
+pkgrel=14
pkgdesc="Caffe 1.0 with triNNity extensions"
arch=('x86_64')
url="https://bitbucket.org/STG-TCD/trinnity-caffe"
@@ -13,14 +13,14 @@ depends=(
'python-matplotlib' 'ipython' 'python-networkx' 'python-nose'
'python-pandas' 'python-dateutil' 'python-protobuf' 'python-gflags'
'python-yaml' 'python-pillow' 'python-six' 'python-scikit-image'
- 'opencv>=4.0.0' 'gtk3'
+ 'opencv>=4.0.0' 'gtk3' 'openmp'
)
optdepends=('openblas: OpenBLAS for backend linear algebra ops',
'cblas: Use CBLAS for backend linear algebra ops'
)
makedepends=('cmake')
provides=('caffe')
-conflicts=()
+conflicts=('trinnity-caffe-cuda-git' 'trinnity-caffe-cudnn-git')
source=("${_srcname}"::"git+https://bitbucket.org/STG-TCD/trinnity-caffe.git")
sha256sums=('SKIP')
@@ -47,7 +47,7 @@ prepare() {
-DUSE_LMDB=OFF \
-DUSE_HDF5=ON \
-DALLOW_LMDB_NOLOCK=OFF \
- -DUSE_OPENMP=OFF \
+ -DUSE_OPENMP=ON \
-DBLAS=CBLAS \
-D python_version=3 \
-DCMAKE_INSTALL_PREFIX:PATH=${pkgdir}/usr \