summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Anderson2018-11-06 15:13:04 +0000
committerAndrew Anderson2018-11-06 15:13:04 +0000
commitdb834918a3453c72ca02dc3eaef7325f47c59470 (patch)
tree126df743d59791dc6db65b6dbfe067ff60d04f35
downloadaur-db834918a3453c72ca02dc3eaef7325f47c59470.tar.gz
init
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD35
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7ea7f4b2b723
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = trinnity-git
+ pkgdesc = C++ library of CNN primitive operations
+ pkgver = 0.5
+ pkgrel = 1
+ url = https://bitbucket.org/STG-TCD/trinnity
+ arch = any
+ license = BSD
+ makedepends = doxygen
+ optdepends = gsl>=2.3: GSL BLAS backend
+ optdepends = atlas-lapack>=3.10.3: ATLAS BLAS backend
+ optdepends = openblas-lapack>=0.2.19: OpenBLAS BLAS backend
+ optdepends = intel-mkl>=2017.17.0.1.1.132: Intel MKL BLAS backend
+ optdepends = clblas>=2.12: clBLAS BLAS backend
+ optdepends = cblas: Plain old CBLAS backend
+ conflicts = trinnity
+ source = trinnity::git+https://bitbucket.org/STG-TCD/trinnity
+ md5sums = SKIP
+
+pkgname = trinnity-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..561dd544ceb5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Andrew Anderson <andersan@tcd.ie>
+pkgname=trinnity-git
+_srcname=trinnity
+pkgver=0.5
+pkgrel=1
+pkgdesc="C++ library of CNN primitive operations"
+arch=('any')
+url="https://bitbucket.org/STG-TCD/trinnity"
+license=('BSD')
+groups=()
+depends=()
+makedepends=('doxygen')
+checkdepends=()
+optdepends=('gsl>=2.3: GSL BLAS backend'
+ 'atlas-lapack>=3.10.3: ATLAS BLAS backend'
+ 'openblas-lapack>=0.2.19: OpenBLAS BLAS backend'
+ 'intel-mkl>=2017.17.0.1.1.132: Intel MKL BLAS backend'
+ 'clblas>=2.12: clBLAS BLAS backend'
+ 'cblas: Plain old CBLAS backend'
+ )
+provides=()
+conflicts=("trinnity")
+replaces=()
+backup=()
+options=()
+source=("${_srcname}"::"git+https://bitbucket.org/STG-TCD/${_srcname}")
+
+md5sums=("SKIP")
+
+package() {
+ make -C $srcdir/STG-* DESTDIR=$pkgdir doc
+ make -C $srcdir/STG-* DESTDIR=$pkgdir install
+ make -C $srcdir/STG-* DESTDIR=$pkgdir install-arm32
+ make -C $srcdir/STG-* DESTDIR=$pkgdir install-arm64
+}