summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBet42020-02-27 22:43:32 +0800
committerBet42020-02-27 22:43:32 +0800
commit656bc25c7a019b6d3d3e57dadc421be0047f9059 (patch)
tree71237fdd1042bdb848322f498efdc298dc202a30
downloadaur-656bc25c7a019b6d3d3e57dadc421be0047f9059.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..22a4d86a1972
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = triton-git
+ pkgdesc = Dynamic binary analysis framework
+ pkgver = v0.7.r102.gfb3241e9
+ pkgrel = 1
+ url = https://triton.quarkslab.com/
+ arch = x86_64
+ license = Apache
+ makedepends = git
+ makedepends = boost
+ depends = capstone
+ depends = z3
+ depends = python
+ provides = triton
+ conflicts = triton
+ source = triton-git::git+https://github.com/JonathanSalwan/Triton.git
+ sha256sums = SKIP
+
+pkgname = triton-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1454fc2106e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Bet4 <0xbet4@gmail.com>
+
+# Special thanks to Alexey Nurmukhametov that provided the
+# original PKGBUILD from triton (https://aur.archlinux.org/packages/triton/)
+
+_pkgname=triton
+pkgname=${_pkgname}-git
+pkgver=v0.7.r102.gfb3241e9
+pkgrel=1
+pkgdesc='Dynamic binary analysis framework'
+url='https://triton.quarkslab.com/'
+arch=('x86_64')
+license=('Apache')
+depends=('capstone' 'z3' 'python')
+makedepends=('git' 'boost')
+provides=(${_pkgname})
+conflicts=(${_pkgname})
+source=("$pkgname::git+https://github.com/JonathanSalwan/Triton.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $pkgname
+ cmake ./ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd $pkgname
+ make DESTDIR="$pkgdir" install
+}