summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian "Beej Jorgensen" Hall2022-07-27 13:49:12 -0700
committerBrian "Beej Jorgensen" Hall2022-07-27 13:49:12 -0700
commita50ead94edc73a2141162252e4500fa94f104439 (patch)
treeaa7d861366d9548288e363ac6cffa876881d0317
parent70f1bede260b2d46d8f419f7af777b4f8164e133 (diff)
downloadaur-trn.tar.gz
update for new heimdal, build errors
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rw-r--r--trn-4.0-test77-aur.patch120
-rw-r--r--trn.install12
4 files changed, 142 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 08850a0faabc..f8a2c1adbbb5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = trn
pkgdesc = Text-based threaded Usenet newsreader
pkgver = 4.0test77
- pkgrel = 4
+ pkgrel = 5
url = http://trn.sourceforge.net/
+ install = trn.install
arch = i686
arch = x86_64
license = custom
makedepends = patch
makedepends = expect
makedepends = bison
- depends = heimdal-aur
+ depends = heimdal
depends = ncurses
optdepends = aspell: spellcheck support
optdepends = sendmail: (or any outgoing mailer) outgoing email support
@@ -17,8 +18,7 @@ pkgbase = trn
source = trn-4.0-test77-aur.patch
source = configbot
md5sums = e0680ae4e6062747f88ba982326ac4c0
- md5sums = 227db01e410765accad9a51520c837a4
+ md5sums = cbe0903d86aa2a016093c0a2dd9604ef
md5sums = 852f1309e9681bc340682484bd2322dc
pkgname = trn
-
diff --git a/PKGBUILD b/PKGBUILD
index 04b8b0843335..e4ccb3fdfc90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,20 @@
pkgname=trn
pkgver=4.0test77
-pkgrel=4
+pkgrel=5
pkgdesc="Text-based threaded Usenet newsreader"
arch=('i686' 'x86_64')
url="http://trn.sourceforge.net/"
license=('custom')
-depends=('heimdal-aur' 'ncurses')
+depends=('heimdal' 'ncurses')
makedepends=('patch' 'expect' 'bison')
optdepends=('aspell: spellcheck support'
'sendmail: (or any outgoing mailer) outgoing email support')
source=('http://downloads.sourceforge.net/trn/trn-4.0-test77.tar.gz'
'trn-4.0-test77-aur.patch' 'configbot')
+install=trn.install
md5sums=('e0680ae4e6062747f88ba982326ac4c0'
- '227db01e410765accad9a51520c837a4'
+ 'cbe0903d86aa2a016093c0a2dd9604ef'
'852f1309e9681bc340682484bd2322dc')
prepare() {
@@ -25,6 +26,9 @@ prepare() {
# to be used as the speller:
patch -Np1 < ${srcdir}/trn-4.0-test77-aur.patch
+ # The heimdal library really shouldn't be here
+ export LD_LIBRARY_PATH=/usr/heimdal/lib:$LD_LIBRARY_PATH
+
# the Configure script is very very interactive, so we
# let expect handle it. This expect script runs the
# Configure script:
@@ -35,6 +39,7 @@ build() {
cd "$srcdir/trn-4.0-test77"
# build it!
+
make
}
diff --git a/trn-4.0-test77-aur.patch b/trn-4.0-test77-aur.patch
index 287ba53a9c40..7d9e0718203d 100644
--- a/trn-4.0-test77-aur.patch
+++ b/trn-4.0-test77-aur.patch
@@ -1,6 +1,6 @@
diff -Naur trn-4.0-test77/Configure trn-4.0-test77-aur/Configure
--- trn-4.0-test77/Configure 2010-09-01 23:12:26.000000000 -0700
-+++ trn-4.0-test77-aur/Configure 2013-04-01 10:02:17.966843649 -0700
++++ trn-4.0-test77-aur/Configure 2022-07-27 12:45:50.403340652 -0700
@@ -3047,6 +3047,7 @@
echo "Checking for GNU cc in disguise and/or its version number..." >&4
$cat >gccvers.c <<EOM
@@ -41,9 +41,125 @@ diff -Naur trn-4.0-test77/Configure trn-4.0-test77-aur/Configure
main()
{
struct tm foo;
+diff -Naur trn-4.0-test77/scan.c trn-4.0-test77-aur/scan.c
+--- trn-4.0-test77/scan.c 2000-05-24 22:11:42.000000000 -0700
++++ trn-4.0-test77-aur/scan.c 2022-07-27 13:18:12.406702116 -0700
+@@ -16,6 +16,40 @@
+ #include "EXTERN.h"
+ #include "sorder.h"
+
++long* s_ent_sort; /* sorted list of entries in the context */
++long s_ent_sort_max; /* maximum index of sorted array */
++long s_ent_sorted_max; /* maximum index *that is sorted* */
++long* s_ent_index; /* indexes into ent_sorted */
++long s_ent_index_max; /* maximum entry number added */
++
++int s_page_size; /* number of entries allocated for page */
++ /* (usually fixed, > max screen lines) */
++PAGE_ENT* page_ents; /* array of entries on page */
++/* -1 means not initialized for top and bottom entry */
++long s_top_ent; /* top entry on page */
++long s_bot_ent; /* bottom entry (note change) */
++bool s_refill; /* does the page need refilling? */
++/* refresh entries */
++bool s_ref_all; /* refresh all on page */
++bool s_ref_top; /* top status bar */
++bool s_ref_bot; /* bottom status bar */
++/* -1 for the next two entries means don't refresh */
++short s_ref_status; /* line to start refreshing status from */
++short s_ref_desc; /* line to start refreshing descript. from */
++/* screen sizes */
++short s_top_lines; /* lines for top status bar */
++short s_bot_lines; /* lines for bottom status bar */
++short s_status_cols; /* characters for status column */
++short s_cursor_cols; /* characters for cursor column */
++short s_itemnum_cols; /* characters for item number column */
++short s_desc_cols; /* characters for description column */
++/* pointer info */
++short s_ptr_page_line; /* page_ent index */
++long s_flags; /* misc. flags */
++
++/* current context type (for fast switching) */
++int s_cur_type;
++
+ void
+ s_init_context(cnum,type)
+ int cnum,type;
+diff -Naur trn-4.0-test77/scan.h trn-4.0-test77-aur/scan.h
+--- trn-4.0-test77/scan.h 2000-05-24 22:11:42.000000000 -0700
++++ trn-4.0-test77-aur/scan.h 2022-07-27 13:18:48.943369305 -0700
+@@ -64,36 +64,36 @@
+
+ /* the current values */
+
+-long* s_ent_sort; /* sorted list of entries in the context */
+-long s_ent_sort_max; /* maximum index of sorted array */
+-long s_ent_sorted_max; /* maximum index *that is sorted* */
+-long* s_ent_index; /* indexes into ent_sorted */
+-long s_ent_index_max; /* maximum entry number added */
++extern long* s_ent_sort; /* sorted list of entries in the context */
++extern long s_ent_sort_max; /* maximum index of sorted array */
++extern long s_ent_sorted_max; /* maximum index *that is sorted* */
++extern long* s_ent_index; /* indexes into ent_sorted */
++extern long s_ent_index_max; /* maximum entry number added */
+
+-int s_page_size; /* number of entries allocated for page */
++extern int s_page_size; /* number of entries allocated for page */
+ /* (usually fixed, > max screen lines) */
+-PAGE_ENT* page_ents; /* array of entries on page */
++extern PAGE_ENT* page_ents; /* array of entries on page */
+ /* -1 means not initialized for top and bottom entry */
+-long s_top_ent; /* top entry on page */
+-long s_bot_ent; /* bottom entry (note change) */
+-bool s_refill; /* does the page need refilling? */
++extern long s_top_ent; /* top entry on page */
++extern long s_bot_ent; /* bottom entry (note change) */
++extern bool s_refill; /* does the page need refilling? */
+ /* refresh entries */
+-bool s_ref_all; /* refresh all on page */
+-bool s_ref_top; /* top status bar */
+-bool s_ref_bot; /* bottom status bar */
++extern bool s_ref_all; /* refresh all on page */
++extern bool s_ref_top; /* top status bar */
++extern bool s_ref_bot; /* bottom status bar */
+ /* -1 for the next two entries means don't refresh */
+-short s_ref_status; /* line to start refreshing status from */
+-short s_ref_desc; /* line to start refreshing descript. from */
++extern short s_ref_status; /* line to start refreshing status from */
++extern short s_ref_desc; /* line to start refreshing descript. from */
+ /* screen sizes */
+-short s_top_lines; /* lines for top status bar */
+-short s_bot_lines; /* lines for bottom status bar */
+-short s_status_cols; /* characters for status column */
+-short s_cursor_cols; /* characters for cursor column */
+-short s_itemnum_cols; /* characters for item number column */
+-short s_desc_cols; /* characters for description column */
++extern short s_top_lines; /* lines for top status bar */
++extern short s_bot_lines; /* lines for bottom status bar */
++extern short s_status_cols; /* characters for status column */
++extern short s_cursor_cols; /* characters for cursor column */
++extern short s_itemnum_cols; /* characters for item number column */
++extern short s_desc_cols; /* characters for description column */
+ /* pointer info */
+-short s_ptr_page_line; /* page_ent index */
+-long s_flags; /* misc. flags */
++extern short s_ptr_page_line; /* page_ent index */
++extern long s_flags; /* misc. flags */
+
+ EXT int s_num_contexts INIT(0);
+ /* array of context structures */
+@@ -102,7 +102,7 @@
+ /* current context number */
+ EXT int s_cur_context INIT(0);
+ /* current context type (for fast switching) */
+-int s_cur_type;
++extern int s_cur_type;
+
+ /* options */
+ /* show item numbers by default */
diff -Naur trn-4.0-test77/Speller.SH trn-4.0-test77-aur/Speller.SH
--- trn-4.0-test77/Speller.SH 2000-05-24 22:11:41.000000000 -0700
-+++ trn-4.0-test77-aur/Speller.SH 2010-09-22 18:10:34.000000000 -0700
++++ trn-4.0-test77-aur/Speller.SH 2022-07-27 12:45:50.403340652 -0700
@@ -16,7 +16,7 @@
# what pager you use--if you have kernal paging use cat
pager="\${PAGER-$pager}"
diff --git a/trn.install b/trn.install
new file mode 100644
index 000000000000..4a62e20af29b
--- /dev/null
+++ b/trn.install
@@ -0,0 +1,12 @@
+post_install() {
+ cat << _EOF_
+-------------------------------------------------------------
+If you get a libhdb.so error when running trn, set
+your LD_LIBRARY_PATH:
+
+ export LD_LIBRARY_PATH=/usr/heimdal/lib:\$LD_LIBRARY_PATH
+
+on the command line, and/or in your shell's rc script.
+-------------------------------------------------------------
+_EOF_
+}