summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBeej Jorgensen2015-07-28 21:18:18 -0700
committerBeej Jorgensen2015-07-28 21:18:18 -0700
commit70f1bede260b2d46d8f419f7af777b4f8164e133 (patch)
treeece1bb8767f240a24623f72d5f3daac03a2d45c8
downloadaur-70f1bede260b2d46d8f419f7af777b4f8164e133.tar.gz
Version 4.0test77-4
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD57
-rw-r--r--configbot76
-rw-r--r--trn-4.0-test77-aur.patch55
4 files changed, 212 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..08850a0faabc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = trn
+ pkgdesc = Text-based threaded Usenet newsreader
+ pkgver = 4.0test77
+ pkgrel = 4
+ url = http://trn.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = patch
+ makedepends = expect
+ makedepends = bison
+ depends = heimdal-aur
+ depends = ncurses
+ optdepends = aspell: spellcheck support
+ optdepends = sendmail: (or any outgoing mailer) outgoing email support
+ source = http://downloads.sourceforge.net/trn/trn-4.0-test77.tar.gz
+ source = trn-4.0-test77-aur.patch
+ source = configbot
+ md5sums = e0680ae4e6062747f88ba982326ac4c0
+ md5sums = 227db01e410765accad9a51520c837a4
+ md5sums = 852f1309e9681bc340682484bd2322dc
+
+pkgname = trn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..04b8b0843335
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Beej Jorgensen <beej@beej.us>
+# Contributor: Beej Jorgensen <beej@beej.us>
+
+pkgname=trn
+pkgver=4.0test77
+pkgrel=4
+pkgdesc="Text-based threaded Usenet newsreader"
+arch=('i686' 'x86_64')
+url="http://trn.sourceforge.net/"
+license=('custom')
+depends=('heimdal-aur' 'ncurses')
+makedepends=('patch' 'expect' 'bison')
+optdepends=('aspell: spellcheck support'
+ 'sendmail: (or any outgoing mailer) outgoing email support')
+source=('http://downloads.sourceforge.net/trn/trn-4.0-test77.tar.gz'
+ 'trn-4.0-test77-aur.patch' 'configbot')
+md5sums=('e0680ae4e6062747f88ba982326ac4c0'
+ '227db01e410765accad9a51520c837a4'
+ '852f1309e9681bc340682484bd2322dc')
+
+prepare() {
+ cd "$srcdir/trn-4.0-test77"
+
+ # fixes in include order to allow builds, and a fix to allow aspell
+ # to be used as the speller:
+ patch -Np1 < ${srcdir}/trn-4.0-test77-aur.patch
+
+ # the Configure script is very very interactive, so we
+ # let expect handle it. This expect script runs the
+ # Configure script:
+ expect -f $srcdir/configbot
+}
+
+build() {
+ cd "$srcdir/trn-4.0-test77"
+
+ # build it!
+ make
+}
+
+package() {
+ cd "$srcdir/trn-4.0-test77"
+
+ # install, forcing the paths to what was set in Configure:
+ make \
+ rnbin=${pkgdir}/usr/bin \
+ rnlib=${pkgdir}/usr/lib/trn \
+ inewsbin=${pkgdir}/usr/bin \
+ mansrc=${pkgdir}/usr/share/man/man1 \
+ install
+
+ # custom license install
+ install -m644 -D LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
+
+# vim:set ts=2 sw=2 et:
+
diff --git a/configbot b/configbot
new file mode 100644
index 000000000000..59cd9e901ff9
--- /dev/null
+++ b/configbot
@@ -0,0 +1,76 @@
+#!/usr/bin/expect
+
+spawn ./Configure
+expect {
+ "Would you like to see the instructions?" { send n\r ; exp_continue; }
+ "Which of these apply, if any?" { send linux\r ; exp_continue; }
+ "Operating system name?" { send linux\r ; exp_continue; }
+ "Select the news spool support (\"local\", \"nntp\", or \"both\"):" { send both\r ; exp_continue; }
+ "Do you want to use generic user-authentication?" { send y\r ; exp_continue; }
+ "Enter \"local\", a server name, or a file name (~name ok):" { send local\r ; exp_continue; }
+ "Do you expect to run these scripts and binaries on multiple machines?" { send n\r ; exp_continue; }
+ "Installation prefix to use? (~name ok)" { send /usr\r ; exp_continue; }
+ "Where is the news library directory for local news? (~name ok)" { send /usr/lib/news\r ; exp_continue; }
+ "Where is the newsgroups file? (\"none\" ok) (~name ok)" { send /usr/lib/news/newsgroups\r ; exp_continue; }
+ "Where is the subscriptions file? (\"none\" ok) (~name ok)" { send /usr/lib/news/subscriptions\r ; exp_continue; }
+ "Pathname where trn's inews will reside? (\"none\" ok) (~name ok)" { send /usr/bin\r ; exp_continue; }
+ "Which inews should be used for posting local articles? (~name ok)" { send inews\r ; exp_continue; }
+ "Where is news spooled? (~name ok)" { send /usr/spool/news\r ; exp_continue; }
+ "Enter a local directory for overview files or \"none\": (~name ok)" { send /usr/spool/news\r ; exp_continue; }
+ "Where is the overview.fmt file for this database? (\"none\" ok) (~name ok)" { send /usr/lib/news/overview.fmt\r ; exp_continue; }
+ "Enter a local directory for thread files or \"none\": (~name ok)" { send /usr/spool/news\r ; exp_continue; }
+ "Where is the active file for local news? (~name ok)" { send /usr/lib/news/active\r ; exp_continue; }
+ "Where is active.times? (\"none\" ok) (~name ok)" { send /usr/lib/news/active.times\r ; exp_continue; }
+ "Do you want trn to default to -x, regardless of name?" { send n\r ; exp_continue; }
+ "Should the -X option be on by default for trn (not rn)?" { send y\r ; exp_continue; }
+ "Pathname where the public executables will reside? (~name ok)" { send /usr/bin\r ; exp_continue; }
+ "What directory name should be used for the install? (~name ok) \\\[/usr/bin\\\]" { send /usr/bin\r ; exp_continue; }
+ "What is the distribution code for your local organization?" { send none\r ; exp_continue; }
+ "What is the distribution code for your organization?" { send none\r ; exp_continue; }
+ "What is the distribution code for your city?" { send none\r ; exp_continue; }
+ "What is the distribution code for your state/province?" { send none\r ; exp_continue; }
+ "What is the distribution code for your multi-state region?" { send none\r ; exp_continue; }
+ "What is the distribution code for your country?" { send none\r ; exp_continue; }
+ "What is the distribution code for your continent?" { send none\r ; exp_continue; }
+ "Use which C compiler?" { send cc\r ; exp_continue; }
+ "What hostname goes on the From line of this machine's postings?" { send \r ; exp_continue; }
+ "Where do the manual pages (source) go? (~name ok) \\\[/usr/man/man1\\\]" { send /usr/share/man/man1\r ; exp_continue; }
+ "What directory name should be used for the install? (~name ok)\r\n\\\[/usr/share/man/man1\\\]" { send /usr/share/man/man1\r ; exp_continue; }
+ "Pathname where the private library files will reside? (~name ok)" { send /usr/lib/trn\r ; exp_continue; }
+ "What directory name should be used for the install? (~name ok)\r\n\\\[/usr/lib/trn\\\]" { send /usr/lib/trn\r ; exp_continue; }
+ "Which interactive speller should we use? (\"none\" ok)" { send -- "aspell -c\r" ; exp_continue; }
+ "What options should be used? (\"none\" ok)" { send none\r ; exp_continue; }
+ "What global mimecap file should trn use? (\"none\" ok) (~name ok)" { send /usr/etc/mimecap\r ; exp_continue; }
+ "Organization:" { send "Example.com Inc\r" ; exp_continue; }
+ "Do you want to include strn's scan and score features?" { send y\r ; exp_continue; }
+ "Directories to use for library searches?" { send "/usr/local/lib /lib /usr/lib /usr/heimdal/lib\r" ; exp_continue; }
+ "What is the file extension used for shared libraries?" { send so\r ; exp_continue; }
+ "Any additional libraries?" { send -- "-lresolv -lhdb -lnsl\r" ; exp_continue; }
+ "What optimizer/debugger flag should be used?" { send -- -O\r ; exp_continue; }
+ "Any additional cc flags?" { send -- -I/usr/local/include\r ; exp_continue; }
+ "Any additional ld flags (NOT including libraries)?" { send -- "-L/usr/local/lib -L/usr/heimdal/lib\r" ; exp_continue; }
+ "Berkeley/V7 format for full name in /etc/passwd?" { send y\r ; exp_continue; }
+ "Shall I use /usr/bin/nm to extract C symbols from the libraries?" { send n\r ; exp_continue; }
+ "Should ORGANIZATION be ignored?" { send n\r ; exp_continue; }
+ "Does your mailer understand INTERNET addresses?" { send y\r ; exp_continue; }
+ "News admin login?" { send root\r ; exp_continue; }
+ "Would you like to see that again?" { send n\r ; exp_continue; }
+ "Do you have buffering (printed all at once)?" { send y\r ; exp_continue; }
+ "Do you have buffering on stdout to terminals?" { send y\r ; exp_continue; }
+ "Some systems have problems with vfork(). Do you want to use it?" { send n\r ; exp_continue; }
+ "What is the default editor on your system?" { send /usr/bin/vi\r ; exp_continue; }
+ "Mail transport agent to be used?" { send /usr/bin/mail\r ; exp_continue; }
+ "In which file is yet-to-be-read mail spooled? (~name ok)" { send /var/mail/%L\r ; exp_continue; }
+ "What's the first character of a mailbox file?" { send F\r ; exp_continue; }
+ "What pager is used on your system?" { send /bin/less\r; exp_continue; }
+ "Preferred shell to be used? (~name ok)" { send /bin/bash\r ; exp_continue; }
+ "Which compiler compiler (yacc or bison -y) shall I use?" { send yacc\r; exp_continue; }
+ "Where do the manual pages (source) go?" { send /usr/share/man/man1\r; exp_continue; }
+ "\\\[Type return to start printing the test characters\\\]" { send \r ; exp_continue; }
+ "\\\[Type carriage return to continue\\\]" { send \r ; exp_continue; }
+
+ "Press return or use a shell escape to edit config.sh:" { send \r ; exp_continue; }
+ "I see a config.sh file. Shall I use it to set the defaults?" { send n\r ; exp_continue; }
+ "doesn't exist. Use that name anyway?" { send y\r ; exp_continue; }
+}
+
diff --git a/trn-4.0-test77-aur.patch b/trn-4.0-test77-aur.patch
new file mode 100644
index 000000000000..287ba53a9c40
--- /dev/null
+++ b/trn-4.0-test77-aur.patch
@@ -0,0 +1,55 @@
+diff -Naur trn-4.0-test77/Configure trn-4.0-test77-aur/Configure
+--- trn-4.0-test77/Configure 2010-09-01 23:12:26.000000000 -0700
++++ trn-4.0-test77-aur/Configure 2013-04-01 10:02:17.966843649 -0700
+@@ -3047,6 +3047,7 @@
+ echo "Checking for GNU cc in disguise and/or its version number..." >&4
+ $cat >gccvers.c <<EOM
+ #include <stdio.h>
++#include <stdlib.h>
+ int main() {
+ #ifdef __GNUC__
+ #ifdef __VERSION__
+@@ -4096,6 +4097,7 @@
+ echo "Checking your choice of C compiler and flags for coherency..." >&4
+ $cat > try.c <<'EOF'
+ #include <stdio.h>
++#include <stdlib.h>
+ main() { printf("Ok\n"); exit(0); }
+ EOF
+ set X $cc $optimize $ccflags -o try $ldflags try.c $libs
+@@ -4303,6 +4305,7 @@
+ echo "Checking for GNU C Library..." >&4
+ cat >gnulibc.c <<EOM
+ #include <stdio.h>
++#include <stdlib.h>
+ int
+ main()
+ {
+@@ -5490,6 +5493,7 @@
+ $cat >foo.c <<EOCP
+ #include <sys/types.h>
+ #include <sys/wait.h>
++#include <stdlib.h>
+
+ main()
+ {
+@@ -6080,6 +6084,7 @@
+ #ifdef I_SYSSELECT
+ #include <sys/select.h>
+ #endif
++#include <stdlib.h>
+ main()
+ {
+ struct tm foo;
+diff -Naur trn-4.0-test77/Speller.SH trn-4.0-test77-aur/Speller.SH
+--- trn-4.0-test77/Speller.SH 2000-05-24 22:11:41.000000000 -0700
++++ trn-4.0-test77-aur/Speller.SH 2010-09-22 18:10:34.000000000 -0700
+@@ -16,7 +16,7 @@
+ # what pager you use--if you have kernal paging use cat
+ pager="\${PAGER-$pager}"
+ # either the ispell program or "none"
+-ispell=$ispell_prg
++ispell="$ispell_prg"
+ ispell_options=$ispell_options
+ test=${test-test}
+ sed=${sed-sed}