summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2020-02-09 10:15:55 +0800
committerlilac2020-02-09 10:15:55 +0800
commit75825ea5b56c4bccbfcc7d8666f067ab0081eecd (patch)
tree8e19dda3676a8a0f588eb3615a1048e9cdff0847
parentaa69acfccad1d5aa20eb47f20edbaf7670f2bc20 (diff)
downloadaur-75825ea5b56c4bccbfcc7d8666f067ab0081eecd.tar.gz
update by lilac
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD24
2 files changed, 13 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dac32d06dd90..fe892edc514e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,9 @@
pkgbase = trojan-git
pkgdesc = An unidentifiable mechanism that helps you bypass GFW
pkgver = r427.7cfe059
- pkgrel = 2
+ pkgrel = 1
url = https://github.com/trojan-gfw/trojan
arch = x86_64
- arch = i686
- arch = armv7h
- arch = aarch64
license = GPL3
checkdepends = openssl
checkdepends = python
diff --git a/PKGBUILD b/PKGBUILD
index 35d9488fc5c8..2799bc737f35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,10 @@
# Maintainer: Ariel AxionL <axionl@aosc.io>
# Contributor: GreaterFire <GreaterFire@protonmail.com>
-
pkgname=trojan-git
pkgver=r427.7cfe059
-pkgrel=2
+pkgrel=1
pkgdesc="An unidentifiable mechanism that helps you bypass GFW"
-arch=('x86_64' 'i686' 'armv7h' 'aarch64')
+arch=('x86_64')
url="https://github.com/trojan-gfw/trojan"
license=('GPL3')
depends=('boost-libs' 'openssl' 'mariadb-libs')
@@ -20,22 +19,23 @@ backup=('etc/trojan/config.json')
sha512sums=('SKIP')
pkgver() {
- cd "$srcdir/$pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd $pkgname
- cmake -DCMAKE_INSTALL_PREFIX=/usr .
- make
+ cd $pkgname
+ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr .
+ make
}
check() {
- cd $pkgname
- ctest
+ cd $pkgname
+ ctest
}
package() {
- cd $pkgname
- make DESTDIR=$pkgdir install
+ cd $pkgname
+ make DESTDIR=$pkgdir install
}
+# vim set: ts=4 sw=4 et