summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGreaterFire2020-02-08 09:56:43 -0800
committerGreaterFire2020-02-08 09:56:43 -0800
commitaa69acfccad1d5aa20eb47f20edbaf7670f2bc20 (patch)
treedaad325b324444b7b39c16a332f3755fb230d089
parent94185bf536aaa68ad1ba55de8916a442252998d8 (diff)
downloadaur-aa69acfccad1d5aa20eb47f20edbaf7670f2bc20.tar.gz
Rebuild due to boost update and add archs
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD24
2 files changed, 16 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe892edc514e..dac32d06dd90 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,12 @@
pkgbase = trojan-git
pkgdesc = An unidentifiable mechanism that helps you bypass GFW
pkgver = r427.7cfe059
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/trojan-gfw/trojan
arch = x86_64
+ arch = i686
+ arch = armv7h
+ arch = aarch64
license = GPL3
checkdepends = openssl
checkdepends = python
diff --git a/PKGBUILD b/PKGBUILD
index 2799bc737f35..35d9488fc5c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
# Maintainer: Ariel AxionL <axionl@aosc.io>
# Contributor: GreaterFire <GreaterFire@protonmail.com>
+
pkgname=trojan-git
pkgver=r427.7cfe059
-pkgrel=1
+pkgrel=2
pkgdesc="An unidentifiable mechanism that helps you bypass GFW"
-arch=('x86_64')
+arch=('x86_64' 'i686' 'armv7h' 'aarch64')
url="https://github.com/trojan-gfw/trojan"
license=('GPL3')
depends=('boost-libs' 'openssl' 'mariadb-libs')
@@ -19,23 +20,22 @@ backup=('etc/trojan/config.json')
sha512sums=('SKIP')
pkgver() {
- cd "$srcdir/$pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd $pkgname
- cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr .
- make
+ cd $pkgname
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
}
check() {
- cd $pkgname
- ctest
+ cd $pkgname
+ ctest
}
package() {
- cd $pkgname
- make DESTDIR=$pkgdir install
+ cd $pkgname
+ make DESTDIR=$pkgdir install
}
-# vim set: ts=4 sw=4 et