summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMateusz Szychowski (Muttley)2022-03-21 12:53:20 +0100
committerMateusz Szychowski (Muttley)2022-03-21 12:53:20 +0100
commit4987aee2603bbe17ab233e0f3437ebe7e20fe3ae (patch)
tree29262bd3149ae166f6b604c1927e4ab304cd0c22
parentcde456467c296943649fd6afe7532b07a3ca38bd (diff)
downloadaur-4987aee2603bbe17ab233e0f3437ebe7e20fe3ae.tar.gz
Switch clone protocol to https, also use HEAD for counting version number
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5f7499c9b6ca..e2f391e455b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = trompeloeil-git
pkgdesc = Header only C++14 mocking framework
- pkgver = 1020.8b2d213
+ pkgver = 1228.6b27428
pkgrel = 1
url = https://github.com/rollbear/trompeloeil.git
arch = i686
@@ -16,8 +16,7 @@ pkgbase = trompeloeil-git
optdepends = gtest
provides = trompeloeil
conflicts = trompeloeil
- source = trompeloeil-git::git://github.com/rollbear/trompeloeil
+ source = trompeloeil-git::git+https://github.com/rollbear/trompeloeil
md5sums = SKIP
pkgname = trompeloeil-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 3e204242f256..0e027d2cf21a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: muttleyxd <mateusz[ at ]szychowski.it>
pkgname=trompeloeil-git
-pkgver=1020.8b2d213
+pkgver=1228.6b27428
pkgrel=1
pkgdesc="Header only C++14 mocking framework"
arch=('i686' 'x86_64')
@@ -10,13 +10,13 @@ makedepends=('cmake' 'make')
optdepends=('boost' 'catch2' 'criterion' 'cxxtest' 'doctest' 'gtest')
provides=('trompeloeil')
conflicts=('trompeloeil')
-source=("$pkgname::git://github.com/rollbear/trompeloeil")
+source=("$pkgname::git+https://github.com/rollbear/trompeloeil")
md5sums=('SKIP')
pkgver()
{
cd "$srcdir/$pkgname"
- echo $(git rev-list --count master).$(git rev-parse --short master)
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
}
build()