summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Ott2019-04-02 00:48:24 +0200
committerStefan Ott2019-04-02 00:48:24 +0200
commit65c29a4c26136cef493cbe3abc64d4988d19fd4e (patch)
tree13fefa5811cc29c88a98ec6d306b192ff93c8d6b
downloadaur-65c29a4c26136cef493cbe3abc64d4988d19fd4e.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD43
-rw-r--r--trottinett.conf1
-rwxr-xr-xtrottinett.init13
4 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..683fd3e9f873
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = trottinett
+ pkgdesc = A simple network interface manager
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://code.ott.net/trottinett/
+ arch = x86_64
+ license = GPL
+ depends = dhcpcd
+ depends = wpa_supplicant
+ depends = openrc
+ source = trottinett-0.2.0.tar.gz::https://code.ott.net/trottinett/downloads/trottinett-0.2.0.tar.gz
+ sha256sums = 11f772927874c0cbdce2f1ad7d0eb8b0e084d1fb3bc0884aee011e4a05448dd7
+
+pkgname = trottinett
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ae56b10c4cbc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Stefan Ott <stefan@ott.net>
+pkgname=trottinett
+pkgver=0.2.0
+pkgrel=1
+epoch=
+pkgdesc="A simple network interface manager"
+arch=("x86_64")
+url="https://code.ott.net/trottinett/"
+license=("GPL")
+groups=()
+depends=("dhcpcd" "wpa_supplicant" "openrc")
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("trottinett-${pkgver}.tar.gz::https://code.ott.net/trottinett/downloads/trottinett-${pkgver}.tar.gz")
+sha256sums=("11f772927874c0cbdce2f1ad7d0eb8b0e084d1fb3bc0884aee011e4a05448dd7")
+noextract=()
+md5sums=()
+validpgpkeys=()
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ mkdir -p ${pkgdir}/etc/init.d/
+ cp -f ${startdir}/trottinett.init ${pkgdir}/etc/init.d/trottinett
+
+ mkdir -p ${pkgdir}/etc/conf.d/
+ cp -f ${startdir}/trottinett.conf ${pkgdir}/etc/conf.d/trottinett
+
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/trottinett.conf b/trottinett.conf
new file mode 100644
index 000000000000..1a41780184d2
--- /dev/null
+++ b/trottinett.conf
@@ -0,0 +1 @@
+TROTTINETT_OPTS=""
diff --git a/trottinett.init b/trottinett.init
new file mode 100755
index 000000000000..6f9e163be49a
--- /dev/null
+++ b/trottinett.init
@@ -0,0 +1,13 @@
+#!/sbin/openrc-run
+# Copyright 2017-2018 Stefan Ott
+# Distributed under the terms of the GNU General Public License v2
+
+command=/usr/bin/trottinett
+pidfile=/run/trottinett.pid
+name="trottinett network manager"
+command_args=${TROTTINETT_OPTS}
+command_background="yes"
+
+depend() {
+ provide net
+}