summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucki2020-06-19 19:55:21 +0200
committerLucki2020-06-19 19:55:21 +0200
commit7607fc8e2d3377cc33c599706c53fcf115cc8667 (patch)
tree8a57e06f046f00682ba6a30e1da01ae0a21d0e6f
downloadaur-7607fc8e2d3377cc33c599706c53fcf115cc8667.tar.gz
Initial upload: truckersmp-cli 0.1.0-1
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD33
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4d129007eae4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = truckersmp-cli
+ pkgdesc = A simple launcher for TruckersMP to play ATS or ETS2 in multiplayer.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/lhark/truckersmp-cli/
+ arch = x86_64
+ license = MIT
+ makedepends = mingw-w64-gcc
+ makedepends = python-genzshcomp
+ makedepends = python-setuptools
+ depends = python
+ depends = sdl2
+ optdepends = python-vdf: automatic steam account detection
+ optdepends = python-setuptools: get version information
+ optdepends = steam: possibility to use proton
+ optdepends = wine: possibility to use wine
+ source = truckersmp-cli-0.1.0.src.tar.gz::https://github.com/lhark/truckersmp-cli/archive/0.1.0.tar.gz
+ sha512sums = 8153f65a1cfb97a2c051ff69f97a6b2614a8f081b7b44d6dcc2d239862f6febce304a6ab65fe7b85c93a47fe946a7c62dd77298425b9068b08220b7469fc03f7
+
+pkgname = truckersmp-cli
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c41bde376c38
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Lucki <https://aur.archlinux.org/account/Lucki>
+# shellcheck disable=SC2034,2154,2148
+
+pkgname=truckersmp-cli
+pkgver=0.1.0
+pkgrel=1
+source=("$pkgname-$pkgver.src.tar.gz::https://github.com/lhark/$pkgname/archive/$pkgver.tar.gz")
+sha512sums=('8153f65a1cfb97a2c051ff69f97a6b2614a8f081b7b44d6dcc2d239862f6febce304a6ab65fe7b85c93a47fe946a7c62dd77298425b9068b08220b7469fc03f7')
+
+pkgdesc="A simple launcher for TruckersMP to play ATS or ETS2 in multiplayer."
+arch=('x86_64')
+url="https://github.com/lhark/truckersmp-cli/"
+license=('MIT')
+depends=('python' 'sdl2')
+optdepends=('python-vdf: automatic steam account detection'
+ 'python-setuptools: get version information'
+ 'steam: possibility to use proton'
+ 'wine: possibility to use wine')
+makedepends=('mingw-w64-gcc' 'python-genzshcomp' 'python-setuptools')
+
+build() {
+ cd "$pkgname-$pkgver" || exit
+ make
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname-$pkgver" || exit
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+
+ install -Dm644 "$pkgname.bash" "$pkgdir/usr/share/bash-completion/completions/$pkgname"
+ install -Dm644 "_$pkgname" "$pkgdir/usr/share/zsh/site-functions/_$pkgname"
+}