summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Shalygin2017-11-17 20:07:19 +0700
committerKonstantin Shalygin2017-11-17 20:07:35 +0700
commit01319c367c5a9ffcdf24eab045bf04a10e7104ec (patch)
tree239a6cf60e73bffca00b9c85f96df7087e889891
parenta529690668a3fe4720b84a13c9f990db3e7af0eb (diff)
downloadaur-01319c367c5a9ffcdf24eab045bf04a10e7104ec.tar.gz
First try to adopt TrueConf for normal Arch Users.
-rw-r--r--.INSTALL97
-rw-r--r--.SRCINFO28
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD41
-rw-r--r--trueconf.desktop12
-rw-r--r--trueconf.install13
6 files changed, 74 insertions, 122 deletions
diff --git a/.INSTALL b/.INSTALL
deleted file mode 100644
index 8c020ceb2bc8..000000000000
--- a/.INSTALL
+++ /dev/null
@@ -1,97 +0,0 @@
-function cmd_present() {
- command -v "$1" >/dev/null 2>&1
-}
-
-
-#The script is run right before files are extracted. One argument is passed: new package version.
-function pre_install() {
- echo ""
-}
-
-#The script is run right after files are extracted. One argument is passed: new package version.
-function post_install() {
- BASE_TC_PATH="/opt/trueconf"
- STARTUP_SCRIPT="${BASE_TC_PATH}/trueconf-client"
- AUTORUN_SCRIPT="${BASE_TC_PATH}/trueconf-client-autostart"
-
- chmod a+x ${STARTUP_SCRIPT}
- chmod a+x ${AUTORUN_SCRIPT}
-
- #create symbolic link to executable
- LINK_FILE="/usr/bin/trueconf"
- if [ -f ${LINK_FILE} ]; then
- rm ${LINK_FILE}
- fi
-
- if [ ! -f ${LINK_FILE} ]; then
- ln -s -f ${STARTUP_SCRIPT} ${LINK_FILE}
- fi
- # ~create symbolic link to executable
-
- # final preparation
- XDG_DESKTOP_MENU=`which xdg-desktop-menu 2> /dev/null`
- if [ ! -x "$XDG_DESKTOP_MENU" ]; then
- echo "WARNING: Could not find xdg-desktop-menu" >&2
- else
- "$XDG_DESKTOP_MENU" install --novendor --mode system /opt/trueconf/trueconf.desktop
- "$XDG_DESKTOP_MENU" forceupdate --mode system
- fi
- # ~ final preparation
-
- # restart application if running
- pid=`ps axco pid,command | awk '$2 == "trueconf-bin" {print $1; }'`
-
- if [ -n "$pid" ]; then
- for process in "$pid"; do
- kill -s 50 $process
- done
-
- fi
-}
-
-#The script is run right before files are extracted. Two arguments are passed in the following order: new package version, old package version.
-function pre_upgrade() {
- echo ""
-}
-
-#The script is run right after files are extracted. Two arguments are passed in the following order: new package version, old package version.
-function post_upgrade() {
- post_install
-}
-
-#The script is run right before files are removed. One argument is passed: old package version.
-function pre_remove() {
- # remove autostart files
- autostart_dir="${HOME}/.config/autostart"
- if [ -f ${autostart_dir}/trueconf.desktop ]; then
- rm ${autostart_dir}/trueconf.desktop
- fi
-
- if [ -f ${autostart_dir}/trueconf-autostart.desktop ]; then
- rm ${autostart_dir}/trueconf-autostart.desktop
- fi
- # ~remove autostart files
-
- # remove application data
- for USER_DIR in $(ls -d /home/*)
- do
- DATA_DIR="${USER_DIR}/.config/trueconf"
- if [ -d "${DATA_DIR}" ]; then
- rm -rf "${DATA_DIR}"
- fi
- done
- # ~remove application data
-
- # uninstall menu file and update system menu
- #"$XDG_DESKTOP_MENU" uninstall --novendor --mode system /opt/trueconf/trueconf.desktop
- #"$XDG_DESKTOP_MENU" forceupdate --mode system
- # ~uninstall menu file and update system menu
-}
-
-#The script is run right after files are removed. One argument is passed: old package version.
-function post_remove() {
- LINK_FILE="/usr/bin/trueconf"
- if [ -f ${LINK_FILE} ]; then
- rm ${LINK_FILE}
- fi
-} \ No newline at end of file
diff --git a/.SRCINFO b/.SRCINFO
index 79987f0d8e20..3fb2c2a7ebdc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,26 @@
+# Generated by mksrcinfo v8
+# Fri Nov 17 13:06:52 UTC 2017
pkgbase = trueconf
- pkgdesc = SystemTap provides free software (GPL) infrastructure to simplify the gathering of information about the running Linux system.
+ pkgdesc = Video conference client
pkgver = 1.3.1.1038
pkgrel = 1
- url = http://trueconf.com/
- install = .INSTALL
+ url = https://trueconf.ru
+ install = trueconf.install
arch = x86_64
- license = custom:TrueConf
- depends = elfutils
- depends = nss
- depends = python2
- source = http://www.trueconf.ru/download/beta/trueconf-client-1.3.1.1038-amd64.pkg.tar.xz
- sha1sums = 350e2fa3ba24d99eceb1544421f4998fa2a8b52b
+ license = freeware
+ makedepends = libarchive
+ depends = libxslt
+ depends = v4l-utils
+ depends = sqlite
+ depends = gtk2
+ depends = openssl
+ depends = gstreamer0.10
+ optdepends = pulseaudio: audio support with pulseaudio
+ optdepends = apulse-git: audio support without pulseaudio
+ source = https://trueconf.ru/download/trueconf-client-amd64.pkg.tar.xz
+ source = trueconf.desktop
+ sha256sums = d077e5ea44e31968052d98f9c08e383275985b62b9372b0be97826389fce09a7
+ sha256sums = e57c0c5c0e4b1be5b11108df5245f3035c7cd4b492de9e014a14b3871f1cddaf
pkgname = trueconf
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..56af2d4aa1c3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+make/*
+pkg/*
+src/*
+*.deb
+*.tar.* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index ae8f41720f18..86a2d56503e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,32 @@
-pkgname=trueconf
-pkgver=1.3.1.1038
-pkgrel=1
-pkgdesc="SystemTap provides free software (GPL) infrastructure to simplify the gathering of information about the running Linux system."
-url="http://trueconf.com/"
-arch=('x86_64')
-license=('custom:TrueConf')
-depends=('elfutils' 'nss' 'python2')
-source=(http://www.trueconf.ru/download/beta/trueconf-client-${pkgver}-amd64.pkg.tar.xz)
-sha1sums=('350e2fa3ba24d99eceb1544421f4998fa2a8b52b')
-install=.INSTALL
+# Maintainer: Shalygin Konstantin <k0ste@k0ste.ru>
+# Contributor: Shalygin Konstantin <k0ste@k0ste.ru>
+pkgname='trueconf'
+pkgver='1.3.1.1038'
+pkgrel='1'
+pkgdesc='Video conference client'
+arch=('x86_64')
+url="https://${pkgname}.ru"
+license=('freeware')
+depends=('libxslt' 'v4l-utils' 'sqlite' 'gtk2' 'openssl' 'gstreamer0.10')
+optdepends=('pulseaudio: audio support with pulseaudio'
+ 'apulse-git: audio support without pulseaudio')
+makedepends=('libarchive')
+source=("${url}/download/${pkgname}-client-amd64.pkg.tar.xz"
+ "${pkgname}.desktop")
+sha256sums=('d077e5ea44e31968052d98f9c08e383275985b62b9372b0be97826389fce09a7'
+ 'e57c0c5c0e4b1be5b11108df5245f3035c7cd4b492de9e014a14b3871f1cddaf')
+install="${pkgname}.install"
build() {
- cp ${srcdir}/.INSTALL ../
+ cd "${srcdir}"
+ rm -rf "usr/share/menu"
+ install -Dm644 "opt/${pkgname}/${pkgname}.desktop" "usr/share/applications/${pkgname}.desktop"
+ install -Dm644 "${pkgname}.desktop" "usr/share/applications/${pkgname}-apulse.desktop"
+ rm "opt/${pkgname}/${pkgname}-autostart.desktop" "opt/${pkgname}/${pkgname}-client-autostart" "opt/${pkgname}/${pkgname}.desktop"
}
package() {
- cp -r ${srcdir}/opt ${pkgdir}
- cp -r ${srcdir}/usr ${pkgdir}
+ cp -ax "usr" "${pkgdir}"
+ cp -ax "opt" "${pkgdir}"
}
-
-# vim:set ts=2 sw=2 et:
diff --git a/trueconf.desktop b/trueconf.desktop
new file mode 100644
index 000000000000..432c089a990a
--- /dev/null
+++ b/trueconf.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Name=TrueConf (apulse)
+GenericName=Video conference client
+Comment=Fast video conferencing (works with apulse)
+Icon=trueconf
+Type=Application
+Categories=Network;Application;
+Exec=apulse /opt/trueconf/trueconf-client %U
+StartupNotify=false
+Terminal=false
+MimeType=x-scheme-handler/trueconf;x-scheme-handler/visicall;
+X-KDE-Protocols=trueconf
diff --git a/trueconf.install b/trueconf.install
new file mode 100644
index 000000000000..42d20ca08869
--- /dev/null
+++ b/trueconf.install
@@ -0,0 +1,13 @@
+post_install() {
+
+if [ ! -L /usr/bin/trueconf ]; then
+ ln -s /opt/trueconf/trueconf-bin /usr/bin/trueconf
+else
+ rm /usr/bin/trueconf
+fi
+gtk-update-icon-cache -fq /usr/share/icons/hicolor
+}
+
+post_remove() {
+ post_install
+}