summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Werkmeister2018-07-31 00:24:40 +0200
committerLucas Werkmeister2018-07-31 00:24:40 +0200
commit03db8c96d2c9e7be74a867bb3df3166d29cc9a22 (patch)
tree1a5c6a4c1b88f5e4a0ee154756ada0806543f586
parent230a06a4012bc548e300a14084a95de413e986d1 (diff)
downloadaur-03db8c96d2c9e7be74a867bb3df3166d29cc9a22.tar.gz
Fix location of LICENSE file
With -t, the target is always treated as a directory, including the last component. Instead, swap the arguments back into SOURCE DEST order, and use the -T option to ensure that DEST really is a file.
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a3fc45eaeac6..427d43118d30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -54,7 +54,7 @@ package() {
ln -s -- "$target" "$pkgdir/usr/lib/jvm/java-8-graal/$name"
done < META-INF/symlinks
- install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/LICENSE" jre/languages/ruby/LICENSE_TRUFFLERUBY.md
+ install -DTm644 jre/languages/ruby/LICENSE_TRUFFLERUBY.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
ln -s ../lib/jvm/java-8-graal/bin/${pkgname_} "$pkgdir/usr/bin/"
}