summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Werkmeister2019-11-25 00:55:21 +0100
committerLucas Werkmeister2019-11-25 00:55:21 +0100
commit10f575a1754541cf36f976d2e422d595907f6f55 (patch)
treedd46be57ce7fa703b0e0be640e465dd7f1bcfc47
parent15602cded01b38b6e8d8848d486b668dfe561485 (diff)
downloadaur-10f575a1754541cf36f976d2e422d595907f6f55.tar.gz
Turn into virtual package for update to 19.3.0
With the 19.3.0 release, GraalVM supports two Java versions: Java 8 and Java 11. This also affects all sibling packages, including TruffleRuby, so the former truffleruby-bin package is split in two: truffleruby-jdk8-bin and truffleruby-jdk11-bin. To leave old installs functional when they update, this package is retained, but only as a “virtual” package with no contents except for its dependencies. Since this package only used to provide the Java 8 version, it declares a dependency on truffleruby-jdk8-bin now (users may, if they want to, install truffleruby-jdk11-bin additionally or instead). Users should explicitly install the real package; I will remove this one eventually.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD60
2 files changed, 9 insertions, 61 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63c4eb3bd799..e738a14264f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,13 @@
pkgbase = truffleruby-bin
- pkgdesc = Graal based, high-performance implementation of the Ruby language
- pkgver = 19.2.1
+ pkgdesc = Virtual package for backwards compatibility; please directly install truffleruby-jdk8-bin instead
+ pkgver = 19.3.0
pkgrel = 1
url = https://github.com/oracle/truffleruby
arch = x86_64
license = EPL
license = GPL2
license = LGPL2.1
- depends = graal
- provides = truffleruby
- conflicts = truffleruby
- source = https://github.com/oracle/truffleruby/releases/download/vm-19.2.1/ruby-installable-svm-linux-amd64-19.2.1.jar
- sha256sums = 30eb0261c30e2d1d32ae1e4fda768014e45e1b4c4b2933f22f51cdc4149c01f0
+ depends = truffleruby-jdk8-bin
pkgname = truffleruby-bin
diff --git a/PKGBUILD b/PKGBUILD
index 27127260c5bd..9d80b18cb80f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,60 +1,12 @@
# Maintainer: Lucas Werkmeister <mail@lucaswerkmeister.de>
-pkgname_=truffleruby
-pkgname=${pkgname_}-bin
-pkgver_=19.2.1
-pkgver=${pkgver_/-/_}
+pkgname=truffleruby-bin
+pkgver=19.3.0
pkgrel=1
-pkgdesc='Graal based, high-performance implementation of the Ruby language'
+pkgdesc='Virtual package for backwards compatibility; please directly install truffleruby-jdk8-bin instead'
arch=('x86_64')
url='https://github.com/oracle/truffleruby'
license=('EPL' 'GPL2' 'LGPL2.1')
-depends=('graal')
-makedepends=()
-optdepends=()
-provides=("$pkgname_")
-conflicts=("$pkgname_")
-source=("https://github.com/oracle/$pkgname_/releases/download/vm-${pkgver_}/ruby-installable-svm-linux-amd64-${pkgver_}.jar")
-sha256sums=('30eb0261c30e2d1d32ae1e4fda768014e45e1b4c4b2933f22f51cdc4149c01f0')
-
-package() {
- local file eq permissions mode name target
-
- mkdir -p "$pkgdir/usr/lib/jvm/java-8-graal/" "$pkgdir/usr/bin/"
- cp -a -t "$pkgdir/usr/lib/jvm/java-8-graal/" jre/ LICENSE_TRUFFLERUBY.txt 3rd_party_licenses_truffleruby.txt
-
- printf '\n' >> META-INF/permissions
- while read -r file eq permissions; do
- if [[ $eq != '=' ]]; then
- printf >&2 'second word should be "=": %s %s %s\n' "$file" "$eq" "$permissions"
- return 1
- fi
- case $permissions in
- 'rw-------') mode=600;;
- 'rw-r--r--') mode=644;;
- 'rw-rw-r--') mode=664;;
- 'rwxr-xr-x') mode=755;;
- 'rwxrwxr-x') mode=775;;
- 'rwxrwxrwx') continue;; # symbolic link
- *)
- printf >&2 'unknown permissions: %s\n' "$permissions"
- return 1
- ;;
- esac
- chmod "$mode" -- "$pkgdir/usr/lib/jvm/java-8-graal/$file"
- done < META-INF/permissions
-
- printf '\n' >> META-INF/symlinks
- while read -r name eq target; do
- if [[ $eq != '=' ]]; then
- printf >&2 'second word should be "=": %s %s %s\n' "$name" "$eq" "$target"
- return 1
- fi
- mkdir -p -- "$pkgdir/usr/lib/jvm/java-8-graal/$(dirname -- "$name")"
- ln -s -- "$target" "$pkgdir/usr/lib/jvm/java-8-graal/$name"
- done < META-INF/symlinks
-
- install -DTm644 LICENSE_TRUFFLERUBY.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-
- ln -s ../lib/jvm/java-8-graal/bin/${pkgname_} "$pkgdir/usr/bin/"
-}
+depends=('truffleruby-jdk8-bin')
+source=()
+sha256sums=()