summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSanpi2023-05-04 12:52:24 +0200
committerSanpi2023-05-04 12:52:24 +0200
commitc02ef6d81914abcfecc7c19e2fc3309e370ac071 (patch)
treec6311b886e8594d0579408e8b0adbe108e12afba
parent041e583cffc29f788e96c4e3f3640b158bd53952 (diff)
downloadaur-c02ef6d81914abcfecc7c19e2fc3309e370ac071.tar.gz
Downloads depedencies in prepare()
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7eb908dbd78..838869849f9d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = trunk
pkgdesc = Build, bundle & ship your Rust WASM application to the web.
pkgver = 0.16.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/thedodd/trunk/
arch = x86_64
license = APACHE
diff --git a/PKGBUILD b/PKGBUILD
index 430e9c689e33..7912359a0f9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Sanpi <sanpi+aur@homecomputing.fr>
pkgname=trunk
pkgver=0.16.0
-pkgrel=1
+pkgrel=2
pkgdesc='Build, bundle & ship your Rust WASM application to the web.'
arch=('x86_64')
url="https://github.com/thedodd/$pkgname/"
@@ -11,10 +11,16 @@ makedepends=('cargo')
source=("$url/archive/v$pkgver.tar.gz")
sha256sums=('035f3508ad3954aa1117f662f9f59541e7a0059483b15d573a8146d997b54827')
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
build() {
cd "$pkgname-$pkgver"
- cargo build --release
+ cargo build --frozen --release
}
check() {