summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2021-01-09 14:55:51 +0100
committerGrey Christoforo2021-01-09 14:55:51 +0100
commitda7c6ca4f7015931c4ebe29d0b468ae7452d761c (patch)
tree00ab98ea32761e2a6605e501e4cea9981c345b9f
downloadaur-da7c6ca4f7015931c4ebe29d0b468ae7452d761c.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD37
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ddca0dc2e086
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = trunk
+ pkgdesc = Build, bundle & ship your Rust WASM application to the web.
+ pkgver = 0.7.4
+ pkgrel = 1
+ url = https://github.com/rustwasm/wasm-bindgen
+ arch = x86_64
+ license = APACHE
+ license = MIT
+ depends = rust-wasm
+ source = trunk-0.7.4.tar.gz::https://github.com/thedodd/trunk/archive/v0.7.4.tar.gz
+ sha256sums = cab41516583250624e12b0e78379935d60d5fc46cfa4aead8746d119ac615406
+
+pkgname = trunk
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6dcb571962e4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+*.gz
+*.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..08354653a153
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Grey Christoforo <first name at last name dot net>
+pkgname=trunk
+pkgver=0.7.4
+pkgrel=1
+pkgdesc="Build, bundle & ship your Rust WASM application to the web."
+arch=(x86_64)
+url="https://github.com/rustwasm/wasm-bindgen"
+license=(APACHE MIT)
+depends=(
+rust-wasm
+)
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/thedodd/trunk/archive/v${pkgver}.tar.gz")
+sha256sums=('cab41516583250624e12b0e78379935d60d5fc46cfa4aead8746d119ac615406')
+
+prepare() {
+ cd trunk-${pkgver}
+ export CARGO_HOME="${srcdir}/cargo_home"
+ cargo fetch
+}
+
+build() {
+ cd trunk-${pkgver}
+ cargo build --release --frozen --all-features --target-dir=target
+}
+
+check() {
+ cd trunk-${pkgver}
+ cargo test --release --frozen --target-dir=target
+}
+
+package(){
+ cd trunk-${pkgver}
+ find target/release -maxdepth 1 -executable -type f -exec install -Dm 755 "{}" -t "${pkgdir}"/usr/bin \;
+ install -Dt "${pkgdir}/usr/share/licenses/${pkgname}" -m644 LICENSE-MIT
+ install -Dt "${pkgdir}/usr/share/licenses/${pkgname}" -m644 LICENSE-APACHE
+}
+