summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTodd E Johnson2021-09-17 22:38:36 -0500
committerTodd E Johnson2021-09-17 22:38:36 -0500
commitfacda52e933c2245024944df7822b88a880ddb1d (patch)
tree6d52617dcc22931c846da60d94feb26d7115c753
downloadaur-facda52e933c2245024944df7822b88a880ddb1d.tar.gz
Initial Commit
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD51
-rw-r--r--trunk-recorder.service14
-rw-r--r--trunk-recorder.sysusers1
-rw-r--r--trunk-recorder.tmpfiles2
5 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7464c579dffb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = trunk-recorder-git
+ pkgdesc = Records calls from a Trunked Radio System (P25 & SmartNet)
+ pkgver = r1543.9f57d36
+ pkgrel = 1
+ url = https://github.com/robotastic/trunk-recorder
+ arch = x86_64
+ arch = i686
+ arch = armv5
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ makedepends = boost
+ makedepends = cppunit
+ depends = gnuradio
+ depends = gnuradio-osmosdr
+ depends = libuhd
+ source = trunk-recorder-git::git+https://github.com/robotastic/trunk-recorder.git#branch=4.0-beta
+ source = trunk-recorder.service
+ source = trunk-recorder.sysusers
+ source = trunk-recorder.tmpfiles
+ sha256sums = SKIP
+ sha256sums = 413f2090a853422b8987bdb4dfa6cbcf7d5b75dbdb1989d030e7c19d3e9dfb9b
+ sha256sums = f2e06d333ec8a64c869a9cf369015bf6e0b9819d2af259b4d1c411ed3cca78f8
+ sha256sums = c20344ba366fcab3f3552e2b5e537f394406ab634f35c2b8858423ffa63fd0e8
+
+pkgname = trunk-recorder-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c6cf16cec7c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Todd E Johnson <todd@toddejohnson.net>
+pkgname=trunk-recorder-git
+pkgver=r1543.9f57d36
+pkgrel=1
+pkgdesc="Records calls from a Trunked Radio System (P25 & SmartNet)"
+arch=(x86_64 i686 armv5 armv6h armv7h aarch64)
+url="https://github.com/robotastic/trunk-recorder"
+license=("GPL3")
+depends=("gnuradio" "gnuradio-osmosdr" "libuhd")
+makedepends=("git" "cmake" "boost" "cppunit")
+optdepends=()
+source=(${pkgname}::git+"https://github.com/robotastic/trunk-recorder.git#branch=4.0-beta"
+ 'trunk-recorder.service'
+ 'trunk-recorder.sysusers'
+ 'trunk-recorder.tmpfiles')
+sha256sums=('SKIP'
+ '413f2090a853422b8987bdb4dfa6cbcf7d5b75dbdb1989d030e7c19d3e9dfb9b'
+ 'f2e06d333ec8a64c869a9cf369015bf6e0b9819d2af259b4d1c411ed3cca78f8'
+ 'c20344ba366fcab3f3552e2b5e537f394406ab634f35c2b8858423ffa63fd0e8')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ rm -rf build
+ mkdir build
+}
+build() {
+ cd build
+ cmake "../${pkgname}" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd build
+ #DESTDIR="$pkgdir" make install
+ install -D -m 755 "recorder" "$pkgdir/usr/bin/recorder"
+ install -D -m 755 "libgnuradio-op25_repeater.so" "$pkgdir/usr/lib/libgnuradio-op25_repeater.so"
+ install -D -m 755 "libunit_script.so" "$pkgdir/usr/lib/libunit_script.so"
+ install -D -m 755 "libopenmhz_uploader.so" "$pkgdir/usr/lib/libopenmhz_uploader.so"
+ install -D -m 755 "libbroadcastify_uploader.so" "$pkgdir/usr/lib/libbroadcastify_uploader.so"
+ install -D -m644 "../${pkgname}/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D -m644 "../trunk-recorder.service" "$pkgdir/usr/lib/systemd/system/trunk-recorder.service"
+ install -D -m644 "../trunk-recorder.sysusers" "$pkgdir/usr/lib/sysusers.d/trunk-recorder.conf"
+ install -D -m644 "../trunk-recorder.tmpfiles" "$pkgdir/usr/lib/tmpfiles.d/trunk-recorder.conf"
+}
+
diff --git a/trunk-recorder.service b/trunk-recorder.service
new file mode 100644
index 000000000000..e04352be077b
--- /dev/null
+++ b/trunk-recorder.service
@@ -0,0 +1,14 @@
+[Unit]
+Description=Trunk-Recorder
+
+[Service]
+User=trunk-recorder
+Group=trunk-recorder
+Environment=LC_ALL=en_US.utf8
+WorkingDirectory=/var/lib/trunk-recorder
+ExecStart=/usr/bin/recorder --config /etc/trunk-recorder.json
+Restart=always
+
+[Install]
+WantedBy=multi-user.target
+
diff --git a/trunk-recorder.sysusers b/trunk-recorder.sysusers
new file mode 100644
index 000000000000..ba86c2753766
--- /dev/null
+++ b/trunk-recorder.sysusers
@@ -0,0 +1 @@
+u trunk-recorder - "Trunk Recorder daemon" /var/lib/trunk-recorder
diff --git a/trunk-recorder.tmpfiles b/trunk-recorder.tmpfiles
new file mode 100644
index 000000000000..e9cc556f638b
--- /dev/null
+++ b/trunk-recorder.tmpfiles
@@ -0,0 +1,2 @@
+# Override this file with a modified version in /etc/tmpfiles.d/
+d /var/lib/trunk-recorder 0755 trunk-recorder trunk-recorder