summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTodd E Johnson2021-10-15 19:39:30 -0500
committerTodd E Johnson2021-10-15 19:39:30 -0500
commitff045994e3b7496d72e0cf169ca25e66f4eeabba (patch)
treedf0754a985b38b1e82fe7c42db68ddc2dc62cbec
parent999796f33fca648918c50ed8f983542ea93fff92 (diff)
downloadaur-ff045994e3b7496d72e0cf169ca25e66f4eeabba.tar.gz
Simplify name and add provides and conflicts
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD23
2 files changed, 17 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cdb9377b8e49..5efb389cd1b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = trunk-recorder-git
pkgdesc = Records calls from a Trunked Radio System (P25 & SmartNet)
pkgver = r1629.b3d1776
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/robotastic/trunk-recorder
arch = x86_64
arch = i686
@@ -20,10 +20,12 @@ pkgbase = trunk-recorder-git
depends = boost-libs
depends = sox
depends = fdkaac
+ provides = trunk-recorder
+ conflicts = trunk-recorder
options = !strip
options = !buildflags
options = debug
- source = trunk-recorder-git::git+https://github.com/robotastic/trunk-recorder.git
+ source = trunk-recorder::git+https://github.com/robotastic/trunk-recorder.git
source = trunk-recorder.service
source = trunk-recorder.sysusers
source = trunk-recorder.tmpfiles
diff --git a/PKGBUILD b/PKGBUILD
index 63f547096944..9296fb9fda7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Todd E Johnson <todd@toddejohnson.net>
-options=(!strip !buildflags debug )
-pkgname=trunk-recorder-git
+options=(!strip !buildflags debug)
+_name=trunk-recorder
+pkgname=${_name}-git
pkgver=r1629.b3d1776
-pkgrel=1
+pkgrel=2
pkgdesc="Records calls from a Trunked Radio System (P25 & SmartNet)"
arch=(x86_64 i686 armv5 armv6h armv7h aarch64)
url="https://github.com/robotastic/trunk-recorder"
@@ -10,7 +11,9 @@ license=("GPL3")
depends=("gnuradio" "gnuradio-osmosdr" "libuhd" "boost" "boost-libs" "sox" "fdkaac")
makedepends=("git" "cmake" "cppunit")
optdepends=()
-source=(${pkgname}::git+"https://github.com/robotastic/trunk-recorder.git"
+conflicts=('trunk-recorder')
+provides=('trunk-recorder')
+source=(${_name}::git+"https://github.com/robotastic/trunk-recorder.git"
'trunk-recorder.service'
'trunk-recorder.sysusers'
'trunk-recorder.tmpfiles')
@@ -20,7 +23,7 @@ sha256sums=('SKIP'
'c20344ba366fcab3f3552e2b5e537f394406ab634f35c2b8858423ffa63fd0e8')
pkgver() {
- cd "$pkgname"
+ cd "$_name"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
@@ -30,7 +33,7 @@ prepare() {
}
build() {
cd build
- cmake "../${pkgname}" \
+ cmake "../${_name}" \
-DCMAKE_INSTALL_PREFIX=/usr
make
}
@@ -39,9 +42,9 @@ package() {
cd build
make DESTDIR="$pkgdir" install
install -D -d -m755 "$pkgdir/etc/trunk-recorder"
- install -D -m644 "../${pkgname}/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -D -m644 "../trunk-recorder.service" "$pkgdir/usr/lib/systemd/system/trunk-recorder.service"
- install -D -m644 "../trunk-recorder.sysusers" "$pkgdir/usr/lib/sysusers.d/trunk-recorder.conf"
- install -D -m644 "../trunk-recorder.tmpfiles" "$pkgdir/usr/lib/tmpfiles.d/trunk-recorder.conf"
+ install -D -m644 "../${_name}/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D -m644 "../${_name}.service" "$pkgdir/usr/lib/systemd/system/${_name}.service"
+ install -D -m644 "../${_name}.sysusers" "$pkgdir/usr/lib/sysusers.d/${_name}.conf"
+ install -D -m644 "../${_name}.tmpfiles" "$pkgdir/usr/lib/tmpfiles.d/${_name}.conf"
}