summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWijnand Modderman-Lenstra2015-06-15 17:00:59 +0200
committerWijnand Modderman-Lenstra2015-06-15 17:00:59 +0200
commit459ce2e0b0d350df83992ccdf1114ae585578e66 (patch)
tree875bb9d50af1f88daffa61c30982af737401f8a3
downloadaur-459ce2e0b0d350df83992ccdf1114ae585578e66.tar.gz
Migrated package
-rw-r--r--.AURINFO25
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD33
3 files changed, 84 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..0c272dca6561
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,25 @@
+pkgbase = trustedqsl
+ pkgdesc = TrustedQSL - Logbook of the World
+ pkgver = 2.0.3
+ pkgrel = 1
+ epoch =
+ url = http://lotw.arrl.org/
+ arch = x86_64
+ arch = i686
+ license = ARRL
+ makedepends = openssl
+ makedepends = expat
+ makedepends = zlib
+ makedepends = wxgtk
+ makedepends = curl
+ makedepends = cmake
+ depends = openssl
+ depends = expat
+ depends = zlib
+ depends = wxgtk
+ depends = curl
+ replaces = tsql
+ source = http://www.arrl.org/files/file/LoTW%20Instructions/tqsl-2.0.3.tgz
+
+pkgname = trustedqsl
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3bca75efc79d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = trustedqsl
+ pkgdesc = TrustedQSL - Logbook of the World
+ pkgver = 2.0.3
+ pkgrel = 1
+ url = http://lotw.arrl.org/
+ arch = x86_64
+ arch = i686
+ license = ARRL
+ makedepends = openssl
+ makedepends = expat
+ makedepends = zlib
+ makedepends = wxgtk
+ makedepends = curl
+ makedepends = cmake
+ depends = openssl
+ depends = expat
+ depends = zlib
+ depends = wxgtk
+ depends = curl
+ replaces = tsql
+ source = http://www.arrl.org/files/file/LoTW%20Instructions/tqsl-2.0.3.tgz
+ md5sums = 0e62df9f8c2fbb4b5d42d3ee9111c75a
+ sha1sums = d1ded1c8e55dcacc194db79a32c9e8fab6995af7
+
+pkgname = trustedqsl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9407cc5ffbb9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Wijnand Modderman-Lenstra <maze@maze.io>
+pkgname=trustedqsl
+pkgver=2.0.3
+pkgrel=1
+epoch=
+pkgdesc="TrustedQSL - Logbook of the World"
+arch=('x86_64' 'i686')
+url="http://lotw.arrl.org/"
+license=('ARRL')
+groups=()
+replaces=(tsql)
+depends=(openssl expat zlib wxgtk curl)
+makedepends=(openssl expat zlib wxgtk curl cmake)
+source=(http://www.arrl.org/files/file/LoTW%20Instructions/tqsl-${pkgver}.tgz)
+md5sums=('0e62df9f8c2fbb4b5d42d3ee9111c75a')
+sha1sums=('d1ded1c8e55dcacc194db79a32c9e8fab6995af7')
+
+build() {
+ cd "$srcdir/tqsl-$pkgver"
+ mkdir -p build
+ cd build
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DwxWidgets_CONFIG_EXECUTABLE='/usr/bin/wx-config-2.8' \
+ -DwxWidgets_wxrc_EXECUTABLE='/usr/bin/wxrc-2.8' \
+ ../
+ make
+}
+
+package() {
+ cd "$srcdir/tqsl-$pkgver/build"
+ make DESTDIR="$pkgdir/" install
+}