summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntoine Lubineau2021-02-28 14:50:32 +0100
committerAntoine Lubineau2021-02-28 14:50:32 +0100
commita2578ffea551ed0d2c25e14171fd5e007a865b11 (patch)
tree199a0a27d8d48956e7943a3d053ebe5b20d84166
parentf9f755cbbbfc720c838276cfcec474e3aeb4846f (diff)
downloadaur-a2578ffea551ed0d2c25e14171fd5e007a865b11.tar.gz
ts: 1.0.1, switch to Debian sources
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD33
2 files changed, 24 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5bc0ce311c62..de81b6c77cf0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
-# Generated by mksrcinfo v8
-# Sat Dec 16 11:04:55 UTC 2017
pkgbase = ts
pkgdesc = A Unix batch system where the tasks spooled run one after the other
- pkgver = 1.0
+ pkgver = 1.0.1
pkgrel = 1
url = http://vicerveza.homeunix.net/~viric/soft/ts/
arch = i686
arch = x86_64
license = GPL2
- source = http://vicerveza.homeunix.net/~viric/soft/ts/ts-1.0.tar.gz
- md5sums = c7589cdc28115d8925794d713ff72dba
+ source = http://deb.debian.org/debian/pool/main/t/task-spooler/task-spooler_1.0.1+dfsg1.orig.tar.xz
+ source = http://deb.debian.org/debian/pool/main/t/task-spooler/task-spooler_1.0.1+dfsg1-1.debian.tar.xz
+ md5sums = 6cd744c43f36d432f303957d60474570
+ md5sums = 943491a4775c81d020e12c9ba2ca42ea
pkgname = ts
diff --git a/PKGBUILD b/PKGBUILD
index 5c5ab052dcc8..c8a2cbec879b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,36 @@
# Contributor: lp76 <l.peduto@gmail.com>
pkgname=ts
-pkgver=1.0
+pkgver=1.0.1
pkgrel=1
+_debrevision="dfsg1"
+_debfullrev="dfsg1-1"
pkgdesc="A Unix batch system where the tasks spooled run one after the other"
arch=('i686' 'x86_64')
url="http://vicerveza.homeunix.net/~viric/soft/ts/"
license=('GPL2')
-source=("http://vicerveza.homeunix.net/~viric/soft/ts/${pkgname}-${pkgver}.tar.gz")
-md5sums=('c7589cdc28115d8925794d713ff72dba')
+source=(
+ "http://deb.debian.org/debian/pool/main/t/task-spooler/task-spooler_${pkgver}+${_debrevision}.orig.tar.xz"
+ "http://deb.debian.org/debian/pool/main/t/task-spooler/task-spooler_${pkgver}+${_debfullrev}.debian.tar.xz"
+)
+md5sums=(
+ '6cd744c43f36d432f303957d60474570'
+ '943491a4775c81d020e12c9ba2ca42ea'
+)
prepare() {
- cd "$srcdir/$pkgname-$pkgver"
- sed -i 's|$(PREFIX)/man/man1|$(PREFIX)/share/man/man1|g' Makefile
- sed -i 's/$(CC) $(LDFLAGS) -o ts/$(CC) $(LDFLAGS) -o tsp/' Makefile
- sed -i 's/$(INSTALL) ts/$(INSTALL) tsp/' Makefile
- sed -i 's/\(^\|\s\)ts/\1tsp/' ts.1
+ cd "$srcdir/$pkgname-$pkgver"
+ patch < ../debian/patches/tsp.patch
+ patch < ../debian/patches/manpage.patch
}
build() {
- cd "$srcdir/$pkgname-$pkgver"
- make
+ cd "$srcdir/$pkgname-$pkgver"
+ make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- make PREFIX="$pkgdir/usr" install
- install -D --mode=0644 TRICKS "$pkgdir/usr/share/doc/tsp/TRICKS"
- mv "$pkgdir/usr/share/man/man1/ts.1" "$pkgdir/usr/share/man/man1/tsp.1.gz"
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX="$pkgdir/usr" install
+ install -D --mode=0644 TRICKS "$pkgdir/usr/share/doc/tsp/TRICKS"
}