summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Tran2016-07-25 22:33:04 +1000
committerVictor Tran2016-07-25 22:33:04 +1000
commit486ff63f118a0847206147b45ce5a0eaeed80f10 (patch)
treee63d9f2a0ce83f6a552d46eb5b150df4cb3d7e51
downloadaur-486ff63f118a0847206147b45ce5a0eaeed80f10.tar.gz
Initial Commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..610c40f0a298
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ts-bt
+ pkgdesc = Bluetooth Management for theShell using BlueZ
+ pkgver = 1.0
+ pkgrel = 0
+ url = https://github.com/vicr123/ts-bt
+ arch = x86_64
+ license = GPL3
+ makedepends = qtchooser
+ makedepends = git
+ depends = bluez-qt
+ source = ts-bt-1.0::git+https://github.com/vicr123/ts-bt#branch=master
+ md5sums = SKIP
+
+pkgname = ts-bt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c97ae13b45a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+
+# Maintainer: Victor Tran <vicr12345 at gmail dot com>
+pkgname=ts-bt
+pkgver=1.0
+pkgrel=0
+pkgdesc="Bluetooth Management for theShell using BlueZ"
+arch=("x86_64")
+url="https://github.com/vicr123/ts-bt"
+license=('GPL3')
+depends=('bluez-qt')
+makedepends=('qtchooser' 'git')
+source=("$pkgname-$pkgver"::'git+https://github.com/vicr123/ts-bt#branch=master')
+md5sums=('SKIP')
+
+build() {
+ cd "$pkgname-$pkgver"
+ qmake
+ make
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ cp "$pkgname-$pkgver/ts-bt" "$pkgdir/usr/bin/"
+ mkdir -p "$pkgdir/usr/share/applications"
+ cp "$pkgname-$pkgver/ts-bt.desktop" "$pkgdir/usr/share/applications"
+}