summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Tran2016-07-14 18:16:19 +1000
committerVictor Tran2016-07-14 18:16:19 +1000
commit5f5f32eabe31fbab4bf39d03b65e41d7e5e119f5 (patch)
tree632312f7ece9de0e2712aa46abb6c54f63530466
downloadaur-5f5f32eabe31fbab4bf39d03b65e41d7e5e119f5.tar.gz
Initial Commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2c36280db3fe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = tspolkit
+ pkgdesc = Polkit Agent for theShell
+ pkgver = 1.0
+ pkgrel = 0
+ url = https://github.com/vicr123/ts-polkitagent
+ arch = x86_64
+ license = GPL3
+ makedepends = qtchooser
+ makedepends = git
+ depends = polkit-qt5
+ source = tspolkit-1.0::git+https://github.com/vicr123/ts-polkitagent#branch=master
+ md5sums = SKIP
+
+pkgname = tspolkit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..546ede9d6495
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+
+# Maintainer: Victor Tran <vicr12345 at gmail dot com>
+pkgname=tspolkit
+pkgver=1.0
+pkgrel=0
+pkgdesc="Polkit Agent for theShell"
+arch=("x86_64")
+url="https://github.com/vicr123/ts-polkitagent"
+license=('GPL3')
+depends=('polkit-qt5')
+makedepends=('qtchooser' 'git')
+source=("$pkgname-$pkgver"::'git+https://github.com/vicr123/ts-polkitagent#branch=master')
+md5sums=('SKIP')
+
+build() {
+ cd "$pkgname-$pkgver"
+ qmake
+ make
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/lib"
+ cp "$pkgname-$pkgver/ts-polkitagent" "$pkgdir/usr/lib/"
+}