summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Tran2016-12-12 21:36:41 +1100
committerVictor Tran2016-12-12 21:36:41 +1100
commit8b38a55b69796bbd865d5e6704c7b290cc0eaee2 (patch)
tree29ef41ec3f9a6bbc3b04d93a314a05d434744159
downloadaur-8b38a55b69796bbd865d5e6704c7b290cc0eaee2.tar.gz
Initial Commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b921cc88e459
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ts-qtplatform
+ pkgdesc = Qt Platform Abstraction for theShell
+ pkgver = 1.0
+ pkgrel = 0
+ url = https://github.com/vicr123/ts-qtplatform
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = qt5-base
+ depends = contemporary-widgets
+ depends = kiconthemes
+ source = ts-qtplatform-1.0::git+https://github.com/vicr123/ts-qtplatform#branch=master
+ md5sums = SKIP
+
+pkgname = ts-qtplatform
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f81ab6c0af94
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+
+# Maintainer: Victor Tran <vicr12345 at gmail dot com>
+pkgname=ts-qtplatform
+pkgver=1.0
+pkgrel=0
+pkgdesc="Qt Platform Abstraction for theShell"
+arch=("x86_64")
+url="https://github.com/vicr123/ts-qtplatform"
+license=('GPL3')
+depends=('qt5-base' 'contemporary-widgets' 'kiconthemes')
+makedepends=('git')
+source=("$pkgname-$pkgver"::'git+https://github.com/vicr123/ts-qtplatform#branch=master')
+md5sums=('SKIP')
+
+build() {
+ cd "$pkgname-$pkgver"
+ qmake
+ make
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/lib/qt/plugins/platformthemes/"
+ cp "$pkgname-$pkgver/libts-qtplatform.so" "$pkgdir/usr/lib/qt/plugins/platformthemes/ts.so"
+}