summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen Zhong2020-10-26 15:24:19 +0800
committerAllen Zhong2020-10-26 15:24:41 +0800
commit17d686dc97c3e4c4bac517a875f028e750141d08 (patch)
tree51740aba9a27883739ad105f4d2c2d5878d32d40
parentab15eae8243e708bc02cd49307258203aaeffe09 (diff)
downloadaur-17d686dc97c3e4c4bac517a875f028e750141d08.tar.gz
tsar-git: update code & fix build errors
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
-rw-r--r--fix_module_path.patch33
3 files changed, 32 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 173c96533b03..d99a7e270144 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = tsar-git
pkgdesc = Taobao System Activity Reporter
- pkgver = 0.241.297a2db
+ pkgver = 0.404.14c1392
pkgrel = 1
url = http://tsar.taobao.org/
- arch = i686
arch = x86_64
license = Apache
makedepends = git
depends = glibc
+ depends = luajit
+ depends = cron
backup = etc/tsar/tsar.conf
source = git://github.com/alibaba/tsar.git
source = fix_module_path.patch
source = fix_apache_log.patch
sha1sums = SKIP
- sha1sums = fcb802d50a4d374b05e9453e688ea6e9e5e40d4d
+ sha1sums = 64f0e29f56e2be08a54ecd6b1819e1c0f97e72cb
sha1sums = 3ad26fcbc9bcbb886caa58e3315eb02edb65534f
pkgname = tsar-git
diff --git a/PKGBUILD b/PKGBUILD
index fa18f3344f51..de41cebea6e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,20 @@
pkgname=tsar-git
_gitname=tsar
-pkgver=0.241.297a2db
+pkgver=0.404.14c1392
pkgrel=1
pkgdesc="Taobao System Activity Reporter"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://tsar.taobao.org/"
license=('Apache')
-depends=('glibc')
+depends=('glibc' 'luajit' 'cron')
makedepends=('git')
backup=('etc/tsar/tsar.conf')
source=("git://github.com/alibaba/$_gitname.git"
"fix_module_path.patch"
"fix_apache_log.patch")
sha1sums=('SKIP'
- 'fcb802d50a4d374b05e9453e688ea6e9e5e40d4d'
+ '64f0e29f56e2be08a54ecd6b1819e1c0f97e72cb'
'3ad26fcbc9bcbb886caa58e3315eb02edb65534f')
pkgver() {
diff --git a/fix_module_path.patch b/fix_module_path.patch
index 73fd6991cfc1..f41b3059e2da 100644
--- a/fix_module_path.patch
+++ b/fix_module_path.patch
@@ -1,11 +1,26 @@
---- a/src/framework.c 2014-05-05 13:34:08.000000000 +0800
-+++ b/src/framework.c 2014-05-05 13:33:52.000000000 +0800
-@@ -55,7 +55,7 @@
- int (*mod_register) (struct module *);
+diff --git a/include/define.h b/include/define.h
+index 0d01e14..40e9d23 100644
+--- a/include/define.h
++++ b/include/define.h
+@@ -58,7 +58,7 @@
- /* get the full path of modules */
-- sprintf(buff, "/usr/local/tsar/modules");
-+ sprintf(buff, "/usr/lib/tsar/modules");
+ #define MOD_INFO_SIZE sizeof(strcut mod_info)
- for (i = 0; i < statis.total_mod_num; i++) {
- mod = &mods[i];
+-#define DEFAULT_MODULE_PATH "/usr/local/tsar/modules"
++#define DEFAULT_MODULE_PATH "/usr/lib/tsar/modules"
+ #define DEFAULT_CONF_FILE_PATH "/etc/tsar/tsar.conf"
+ #define DEFAULT_OUTPUT_FILE_PATH "/var/log/tsar.data"
+ #define MIN_STRING "MIN: "
+diff --git a/lualib/Makefile b/lualib/Makefile
+index d5a3b29..5f65d93 100644
+--- a/lualib/Makefile
++++ b/lualib/Makefile
+@@ -3,7 +3,7 @@ LUASOCKET = luasocket-2.0.2
+ DIRS = $(LUACJSON) $(LUASOCKET)
+
+ INCLUDE_DIR ?= $(CURDIR)/../src/obj/include/luajit-2.0
+-INSTALL_DIR ?= /usr/local/tsar/lualib
++INSTALL_DIR ?= /usr/lib/tsar/lualib
+
+ all:
+ for i in $(DIRS); do tar --no-same-owner -zxf $$i.tar.gz; done