summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Ferreira2015-08-27 11:21:17 -0300
committerRafael Ferreira2015-08-27 11:21:17 -0300
commitaae9901f8b6959e38df937cf7fa75c731a1a3775 (patch)
tree6e00b6b32c10e538311f9eab9d67bd7c64162094
parentd9e480eecb1370f6f342287cbc49683c32fd6d43 (diff)
downloadaur-aae9901f8b6959e38df937cf7fa75c731a1a3775.tar.gz
Update to 2.0.0
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD34
-rw-r--r--fix-manpage.patch11
-rw-r--r--tsc.desktop8
-rw-r--r--tsc.install23
-rw-r--r--tsc.pngbin23721 -> 0 bytes
6 files changed, 65 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1de26931f08..ddcdcf86255e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,32 @@
pkgbase = tsc
- pkgdesc = The Secret Chronicles of Dr. M.
- pkgver = 2.0.0b7
+ pkgdesc = Jump'n'run game with editor and scripting facilities, fork of SMC
+ pkgver = 2.0.0
pkgrel = 1
url = http://www.secretchronicles.de/en/
+ install = tsc.install
arch = i686
arch = x86_64
license = GPL3
+ makedepends = cmake
+ makedepends = ruby
makedepends = gperf
+ makedepends = pkg-config
+ makedepends = bison
makedepends = boost
- makedepends = ruby
- makedepends = doxygen
+ makedepends = gettext
depends = sdl_image
depends = sdl_ttf
depends = sdl_mixer
- depends = cegui-0.7
+ depends = devil
depends = boost-libs
depends = libxml++
- source = ftp://ftp.secretchronicles.de/releases/TSC-2.0.0-beta7.tar.xz
- source = ftp://ftp.secretchronicles.de/releases/TSC-2.0.0-beta7.tar.xz.sig
- source = tsc.desktop
- source = tsc.png
- sha256sums = 37d87c8141ff264cb50d87492a20c5ddae0329e9d62ed46d53894612ca0274b4
- sha256sums = SKIP
- sha256sums = b23544efc282e4f2f7a418f1a55abfc0c8dd0f385d20188da3d6ff842aa29d3b
- sha256sums = 7cd526bf0f61fa8eb65c8df10cad8992a20f934f7c717af1785e087616e67c2f
+ depends = glew
+ depends = pcre
+ depends = gtk-update-icon-cache
+ source = ftp://ftp.secretchronicles.de/releases/TSC-2.0.0.tar.xz
+ source = fix-manpage.patch
+ sha256sums = c8a9ca3975f9de16aa59fab2a7864c3c541963b46c2c40533632c4fc621b407a
+ sha256sums = eb4ac81523e4367ebc9c907e1a4a1d08fec3ddcbca83febaef81eb727a2a8c1f
pkgname = tsc
diff --git a/PKGBUILD b/PKGBUILD
index b4a20a253ba1..2fa8b67b624c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,24 @@
# Maintainer: josephgbr <rafael.f.f1@gmail.com>
+# Co-maintainer: Quintus <quintus@quintilianus.eu>
pkgname=tsc
-pkgver=2.0.0b7
-_ver=2.0.0-beta7
+pkgver=2.0.0
+_ver=$pkgver # $_ver was used for beta, let's keep it for a while
pkgrel=1
-pkgdesc="The Secret Chronicles of Dr. M."
+pkgdesc="Jump'n'run game with editor and scripting facilities, fork of SMC"
arch=('i686' 'x86_64')
url="http://www.secretchronicles.de/en/"
license=('GPL3')
-depends=('sdl_image' 'sdl_ttf' 'sdl_mixer' 'cegui-0.7' 'boost-libs' 'libxml++')
-makedepends=('gperf' 'boost' 'ruby' 'doxygen')
-validpgpkeys=('B1FE958ED5E8468EAA208F4BF1D8799FBCC8BC4F')
-source=("ftp://ftp.secretchronicles.de/releases/TSC-$_ver.tar.xz"{,.sig}
- $pkgname.desktop
- $pkgname.png)
-sha256sums=('37d87c8141ff264cb50d87492a20c5ddae0329e9d62ed46d53894612ca0274b4'
- 'SKIP'
- 'b23544efc282e4f2f7a418f1a55abfc0c8dd0f385d20188da3d6ff842aa29d3b'
- '7cd526bf0f61fa8eb65c8df10cad8992a20f934f7c717af1785e087616e67c2f')
+depends=("sdl_image" "sdl_ttf" "sdl_mixer" "devil" "boost-libs" "libxml++" "glew" "pcre" "gtk-update-icon-cache")
+makedepends=("cmake" "ruby" "gperf" "pkg-config" "bison" "boost" "gettext")
+install="$pkgname.install"
+source=("ftp://ftp.secretchronicles.de/releases/TSC-$_ver.tar.xz" "fix-manpage.patch")
+sha256sums=("c8a9ca3975f9de16aa59fab2a7864c3c541963b46c2c40533632c4fc621b407a"
+ "eb4ac81523e4367ebc9c907e1a4a1d08fec3ddcbca83febaef81eb727a2a8c1f")
+
+prepare() {
+ patch -p1 -i fix-manpage.patch
+}
build() {
cd TSC-$_ver/tsc
@@ -26,17 +27,12 @@ build() {
mkdir build
cd build
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ..
make
}
package() {
cd TSC-$_ver/tsc/build
-
make DESTDIR="$pkgdir/" install
-
- # install desktop file
- install -Dm644 "$srcdir"/$pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
- install -Dm644 "$srcdir"/$pkgname.png "$pkgdir"/usr/share/pixmaps/$pkgname.png
}
diff --git a/fix-manpage.patch b/fix-manpage.patch
new file mode 100644
index 000000000000..afa1800262d0
--- /dev/null
+++ b/fix-manpage.patch
@@ -0,0 +1,11 @@
+--- a/TSC-2.0.0/tsc/CMakeLists.txt 2015-08-18 11:21:45.558257165 +0200
++++ b/TSC-2.0.0/tsc/CMakeLists.txt 2015-08-18 11:22:30.348195821 +0200
+@@ -409,7 +409,7 @@
+ DESTINATION ${sharedir}/worlds
+ COMPONENT worlds)
+ install(FILES "${TSC_SOURCE_DIR}/docs/man/tsc.6"
+- DESTINATION man/man6
++ DESTINATION share/man/man6
+ COMPONENT base)
+ install(FILES "${TSC_SOURCE_DIR}/extras/icons/tsc_icon_16.png"
+ DESTINATION share/icons/hicolor/16x16/apps
diff --git a/tsc.desktop b/tsc.desktop
deleted file mode 100644
index 3c2f14661473..000000000000
--- a/tsc.desktop
+++ /dev/null
@@ -1,8 +0,0 @@
-[Desktop Entry]
-Type=Application
-Name=The Secret Chronicles of Dr. M
-Exec=tsc
-Icon=tsc
-Terminal=false
-Categories=Game;ArcadeGame;
-StartupNotify=false
diff --git a/tsc.install b/tsc.install
new file mode 100644
index 000000000000..5918fb299a45
--- /dev/null
+++ b/tsc.install
@@ -0,0 +1,23 @@
+# arg 1: the new package version
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+# arg 1: the old package version
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+# Copyright © 2013-2015 The TSC Contributors
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
diff --git a/tsc.png b/tsc.png
deleted file mode 100644
index 27bfb7670cb0..000000000000
--- a/tsc.png
+++ /dev/null
Binary files differ