summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-07-15 22:45:19 -0600
committerBrian Bidulock2015-07-15 22:45:19 -0600
commit9ea7f694845c4ad6688601075ebb602fc09fb9a5 (patch)
tree4c72bae8d53d031f8a1e33710189f8c753093f26
downloadaur-9ea7f694845c4ad6688601075ebb602fc09fb9a5.tar.gz
initial version
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD33
-rw-r--r--tsclient2.install10
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5105072b6dac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = tsclient2
+ pkgdesc = Terminal Server Client [tsclient] is a GTK2 frontend for rdesktop and other remote desktop tools.
+ pkgver = 2.0.1
+ pkgrel = 10
+ url = http://sourceforge.net/projects/tsclient
+ install = tsclient2.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = sharutils
+ depends = gnome-desktop2
+ depends = libgnomeui
+ depends = libnm-glib
+ depends = desktop-file-utils
+ conflicts = tsclient
+ source = http://downloads.sourceforge.net/sourceforge/tsclient/tsclient-2.0.1.tar.bz2
+ md5sums = 3de7131156f37c5ef1028a5f03ed021b
+
+pkgname = tsclient2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..161ff7af7e84
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Majki <majki@majki.hu>
+pkgname=tsclient2
+pkgver=2.0.1
+pkgrel=10
+pkgdesc="Terminal Server Client [tsclient] is a GTK2 frontend for rdesktop and other remote desktop tools."
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/tsclient"
+license=('GPL')
+depends=('gnome-desktop2' 'libgnomeui' 'libnm-glib' 'desktop-file-utils')
+makedepends=('sharutils')
+conflicts=('tsclient')
+source=(http://downloads.sourceforge.net/sourceforge/tsclient/tsclient-$pkgver.tar.bz2)
+md5sums=('3de7131156f37c5ef1028a5f03ed021b')
+install=${pkgname}.install
+
+build() {
+ cd "$srcdir/tsclient-$pkgver"
+
+ sed -i '/PKG_CONFIG.*libgnome-2.0/s/libgnome-2.0/libgnome-2.0\ libgnomeui-2.0/' configure
+ sed -i '/Exec/s/.*/Exec=tsclient/' data/tsclient.desktop.in
+ sed -i '/notify_notification_new/s/, NULL//' src/plugins/default/tsc-rdp-connection.c
+ sed -i '/notify_notification_new/s/, NULL//' src/plugins/default/tsc-vnc-connection.c
+ sed -i 's/libnm_glib/libnm-glib/g' configure
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd "$srcdir/tsclient-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
+
diff --git a/tsclient2.install b/tsclient2.install
new file mode 100644
index 000000000000..73cd895ebb59
--- /dev/null
+++ b/tsclient2.install
@@ -0,0 +1,10 @@
+post_install() {
+ gtk-update-icon-cache -f /usr/share/icons/hicolor
+ update-desktop-database -q
+}
+post_remove() {
+ post_install
+}
+post_upgrade() {
+ post_install
+}