summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Gregoratto2019-02-26 10:43:18 +1100
committerStephen Gregoratto2019-02-26 10:43:18 +1100
commit805d5db39090379fe399bba5eca366813ddca188 (patch)
treeeb4feb47e052d1b4bfb411e05d9a000d07d6f96b
downloadaur-805d5db39090379fe399bba5eca366813ddca188.tar.gz
initial release
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD36
-rw-r--r--tscrape-git.patch31
3 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..45ab9c968a46
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = tscrape-git
+ pkgdesc = Twitter feed scraper
+ pkgver = 0.1.r0.gbd299de
+ pkgrel = 1
+ url = https://git.codemadness.org/tscrape.html
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = ISC
+ makedepends = git
+ depends = curl
+ provides = sfeed
+ source = tscrape::git+git://git.codemadness.org/tscrape
+ source = tscrape-git.patch
+ sha256sums = SKIP
+ sha256sums = cfd43838d2172abf6ef708598a3dc4bf2807b30bac637ac2f4a878728586aed2
+
+pkgname = tscrape-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2aba2a6c12da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: KingofToasters <dev at sgregoratto dot me>
+pkgname=tscrape-git
+pkgver=0.1.r0.gbd299de
+pkgrel=1
+pkgdesc='Twitter feed scraper'
+url='https://git.codemadness.org/tscrape.html'
+license=('ISC')
+provides=('sfeed')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+depends=('curl')
+makedepends=('git')
+source=("${pkgname%-git}::git+git://git.codemadness.org/tscrape"
+ "tscrape-git.patch" )
+sha256sums=('SKIP'
+ 'cfd43838d2172abf6ef708598a3dc4bf2807b30bac637ac2f4a878728586aed2')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare(){
+ cd "${pkgname%-git}"
+ patch -Np1 -i "${srcdir}/tscrape-git.patch"
+}
+
+build() {
+ cd "${pkgname%-git}"
+ make
+}
+
+package() {
+ cd "${pkgname%-git}"
+ make DESTDIR="$pkgdir/" install
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENCE"
+}
diff --git a/tscrape-git.patch b/tscrape-git.patch
new file mode 100644
index 000000000000..1a4f9c51e545
--- /dev/null
+++ b/tscrape-git.patch
@@ -0,0 +1,31 @@
+Chunk 1: Change PREFIX variables
+Chunk 2: Append local (C|CXX|LD)FLAGS
+diff -ura tscrape.old/config.mk tscrape.new/config.mk
+--- tscrape.old/config.mk 2019-02-26 10:25:11.124019917 +1100
++++ tscrape.new/config.mk 2019-02-26 10:26:34.482322212 +1100
+@@ -1,9 +1,9 @@
+ # customize below to fit your system
+
+ # paths
+-PREFIX = /usr/local
+-MANPREFIX = ${PREFIX}/man
+-DOCPREFIX = ${PREFIX}/share/doc/tscrape
++PREFIX = /usr
++MANPREFIX = ${PREFIX}/share/man
++DOCPREFIX = ${PREFIX}/share/doc/tscrape-git
+
+ # compiler and linker
+ CC = cc
+@@ -11,9 +11,9 @@
+ RANLIB = ranlib
+
+ # use system flags.
+-TSCRAPE_CFLAGS = ${CFLAGS}
+-TSCRAPE_LDFLAGS = ${LDFLAGS}
+-TSCRAPE_CPPFLAGS = -D_DEFAULT_SOURCE
++TSCRAPE_CFLAGS = ${CFLAGS}
++TSCRAPE_LDFLAGS = ${LDFLAGS}
++TSCRAPE_CPPFLAGS += -D_DEFAULT_SOURCE
+
+ # debug
+ #TSCRAPE_CFLAGS = -fstack-protector-all -O0 -g -std=c99 -Wall -Wextra -pedantic