summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Abernethy2015-08-07 23:28:51 +0200
committerPhilip Abernethy2015-08-07 23:28:51 +0200
commit8622582e313ccb2efbdbb91b8aa59ec4d5818e62 (patch)
tree88796821be21114ce5873724ed3659e85b947c67
parent62e9b9908c56228af628f209d1eb42b57b6a7229 (diff)
downloadaur-8622582e313ccb2efbdbb91b8aa59ec4d5818e62.tar.gz
Updated to 4.3.8
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD14
-rw-r--r--tshock.sh6
3 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 494bd3aa07ed..80713582eb63 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tshock
pkgdesc = A Terraria Server administration modification that runs on the open source TerrariaAPI.
- pkgver = 4.3.5
- pkgrel = 2
+ pkgver = 4.3.8
+ pkgrel = 1
epoch = 1
url = http://tshock.co/xf/
install = tshock.install
@@ -9,11 +9,12 @@ pkgbase = tshock
license = GPL
depends = tmux
depends = mono
- source = https://github.com/NyxStudios/TShock/releases/download/v4.3.5/tshock_4.3.5-release.zip
+ backup = srv/tshock/tshock/config.json
+ source = https://github.com/NyxStudios/TShock/releases/download/v4.3.8/tshock-4.3.8-rel.zip
source = tshock.sh
source = tshock@.service
- sha512sums = b15c1518507a7bf7b700789fb55eb7c2ecc175d1da8585b4d12c118f6f64b8d82a2f72b048d4efc856e841ea48508a925b4717932d045caad5fdd93e3cd60904
- sha512sums = ea25422690dfb8a15436529b56d594530d3a1d4800f337460f70c46b9328bef1ce6898c25f87d5dbc6a33c36ffc18648a189903650581b4529a5db366c50a705
+ sha512sums = ef45fd37e2942b146316139bed3c6d0aa20887d8db32054330bd4272bca0c36aa8804a2972a2ad80cd41856c342ae162e83125005773f97b3cc9b0039f96350c
+ sha512sums = e73ca357516700bbd4ec5e6529320984b81fc7c6abc882181a9a9b3aad32f0d655b7686470fdbf7a953ce1935a79dbed983397aff0bf7ff26a1611dbcca391fb
sha512sums = 563ada981c2e08293462485fd85b2c4e0b190c55ed3bcea4139b955f931d970d97c2bd89fba5b190231e9f2adeddd2c385abd11781bf1a98b13b78b8951bf623
pkgname = tshock
diff --git a/PKGBUILD b/PKGBUILD
index cc4ae0c83dca..726fbf463c6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,28 @@
-# Maintainer: Vincent Post <vincent.post@w1r3.net>
+# Maintainer: Philip Abernethy <chais.z3r0@gmail.com>
pkgname=tshock
-pkgver=4.3.5
+pkgver=4.3.8
# Because of tag 4.2200 is 4.2.2.1228 and tag 4.2202 is 4.2.2.0224 epoch must be 1
epoch=1
-pkgrel=2
+pkgrel=1
pkgdesc="A Terraria Server administration modification that runs on the open source TerrariaAPI."
arch=(any)
url="http://tshock.co/xf/"
license=("GPL")
depends=('tmux'
'mono')
-source=("https://github.com/NyxStudios/TShock/releases/download/v${pkgver}/${pkgname}_${pkgver}-release.zip"
+source=("https://github.com/NyxStudios/TShock/releases/download/v${pkgver}/${pkgname}-${pkgver}-rel.zip"
'tshock.sh'
'tshock@.service')
-sha512sums=('b15c1518507a7bf7b700789fb55eb7c2ecc175d1da8585b4d12c118f6f64b8d82a2f72b048d4efc856e841ea48508a925b4717932d045caad5fdd93e3cd60904'
- 'ea25422690dfb8a15436529b56d594530d3a1d4800f337460f70c46b9328bef1ce6898c25f87d5dbc6a33c36ffc18648a189903650581b4529a5db366c50a705'
+sha512sums=('ef45fd37e2942b146316139bed3c6d0aa20887d8db32054330bd4272bca0c36aa8804a2972a2ad80cd41856c342ae162e83125005773f97b3cc9b0039f96350c'
+ 'e73ca357516700bbd4ec5e6529320984b81fc7c6abc882181a9a9b3aad32f0d655b7686470fdbf7a953ce1935a79dbed983397aff0bf7ff26a1611dbcca391fb'
'563ada981c2e08293462485fd85b2c4e0b190c55ed3bcea4139b955f931d970d97c2bd89fba5b190231e9f2adeddd2c385abd11781bf1a98b13b78b8951bf623')
install=tshock.install
+backup=('srv/tshock/tshock/config.json')
+
package() {
install -d "${pkgdir}/srv/tshock/ServerPlugins/"
install -d "${pkgdir}/etc/conf.d/tshock/"
diff --git a/tshock.sh b/tshock.sh
index 41c9dd0d86f8..989f5741851b 100644
--- a/tshock.sh
+++ b/tshock.sh
@@ -56,8 +56,8 @@ TMUX_CONSOLE=tshock-console-${INSTANCE}
case "$1" in
start)
- if [ ! $(tmux has -t ${TMUX_CONSOLE}) ]; then
- tmux new-session -d -s ${TMUX_CONSOLE} -d "cd ${BASEDIR}; mono TerrariaServer.exe -port ${PORT} -worldpath ${WORLDDIR} -world ${WORLDDIR}/${WORLD}.wld -autocreate ${SIZE}"
+ if [ ! $(tmux has -t ${TMUX_CONSOLE} &> /dev/null) ]; then
+ tmux new-session -d -s ${TMUX_CONSOLE} -d "cd ${BASEDIR}; mono --server --gc=sgen -O=all TerrariaServer.exe -port ${PORT} -worldpath ${WORLDDIR} -world ${WORLDDIR}/${WORLD}.wld -autocreate ${SIZE}"
if [ $? -gt 0 ]; then
exit 1
fi
@@ -79,7 +79,7 @@ case "$1" in
;;
install)
- bash -c "cd ${BASEDIR}; mono TerrariaServer.exe"
+ bash -c "cd ${BASEDIR}; mono --server --gc=sgen -O=all TerrariaServer.exe -worldpath ${WORLDDIR}"
;;
*)