summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Krzyszkowiak2015-06-16 03:51:41 +0200
committerSebastian Krzyszkowiak2015-06-16 03:51:41 +0200
commita80e0640cc00fa13d5c95ac4b9eef6d5e5b7709f (patch)
tree1d06ae14d8804c2a167f5b32f209a17ffac93de5
downloadaur-a80e0640cc00fa13d5c95ac4b9eef6d5e5b7709f.tar.gz
Initial version
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD29
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..97ca8e5b0207
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = tsotc
+ pkgdesc = The Secret of Tremendous Corporation - a point'n'click adventure game about Max Burton, young game developer wannabe, on an unexpected mission to save the game industry.
+ pkgver = 2.2.1.1
+ pkgrel = 1
+ url = http://tremendouscorp.com/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ license = LGPL
+ makedepends = sludge
+ depends = glee
+ depends = alure
+ depends = libvpx
+ depends = sdl
+ depends = dumb
+ depends = xdg-utils
+ source = http://tremendouscorp.com/downloads/sources/tsotc_2.2.1.1.orig.tar.gz
+ source = http://tremendouscorp.com/downloads/sources/tsotc-game_2.2.1.1.src.tar.gz
+ sha256sums = 7f241bf2bf237e719a63a93cfa7c3c104ca13d2d88d14d7b70d685e6907e0a60
+ sha256sums = 7b0fa2a26288f04f4a28608ef3d789ce66f49cf18b3bb7cba9339c0d9aa23f88
+
+pkgname = tsotc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c53d11354172
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Sebastian Krzyszkowiak <dos@dosowisko.net>
+pkgname=tsotc
+pkgver=2.2.1.1
+pkgrel=1
+pkgdesc="The Secret of Tremendous Corporation - a point'n'click adventure game about Max Burton, young game developer wannabe, on an unexpected mission to save the game industry."
+arch=('i686' 'x86_64')
+url='http://tremendouscorp.com/'
+license=('GPL3' 'LGPL')
+depends=('glee' 'alure' 'libvpx' 'sdl' 'dumb' 'xdg-utils')
+makedepends=('sludge')
+source=("http://tremendouscorp.com/downloads/sources/tsotc_$pkgver.orig.tar.gz" "http://tremendouscorp.com/downloads/sources/tsotc-game_$pkgver.src.tar.gz")
+sha256sums=('7f241bf2bf237e719a63a93cfa7c3c104ca13d2d88d14d7b70d685e6907e0a60' '7b0fa2a26288f04f4a28608ef3d789ce66f49cf18b3bb7cba9339c0d9aa23f88')
+
+build() {
+ cd opensludge
+ ./autogen.sh
+ ./configure --prefix=/usr
+ cd ../tsotc
+ make
+}
+
+package() {
+ cd opensludge
+ make DESTDIR="$pkgdir/" install
+ mkdir -p "$pkgdir/usr"
+ cp -r share "$pkgdir/usr/"
+ cd ../tsotc
+ cp gamedata.slg "$pkgdir/usr/share/tsotc/"
+}