summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorthebitstick2020-04-26 22:54:39 -0500
committerthebitstick2020-04-26 22:54:39 -0500
commitab02df5e8380d3334937128e60d52dca7998ead4 (patch)
tree72372d76bb6e5b2d70eea40aba9136dc635097ad
parentff879e0e63c0325e608e567fb0132f43bbd6103e (diff)
downloadaur-ab02df5e8380d3334937128e60d52dca7998ead4.tar.gz
Added desktop file and forgot toot
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0c349b2da18..f77dcdff5d87 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tsubasa
- pkgdesc = Script for sharing screenshots and/or status updates using ihabunek/toot
- pkgver = 0.1.1
- pkgrel = 2
+ pkgdesc = Script for sharing screenshots and/or status updates
+ pkgver = 0.1.3
+ pkgrel = 1
url = https://github.com/thebitstick/tsubasa
arch = any
license = GPL3
@@ -9,10 +9,11 @@ pkgbase = tsubasa
depends = fish
depends = gnome-screenshot
depends = zenity
+ depends = toot
provides = tsubasa
conflicts = tsubasa
- source = https://github.com/thebitstick/tsubasa/archive/0.1.1/tsubasa-0.1.1.tar.gz
- sha512sums = 61dfc737f4a2a3737a31323e2a85fabc857a14f2d81f61303ab24a42f38c2d0da637b18381c5d51afbd543901c493f026779719638f109ea6ca2cdf0eb333235
+ source = https://github.com/thebitstick/tsubasa/archive/0.1.3/tsubasa-0.1.3.tar.gz
+ sha512sums = 3e682bd1626b1e4df72ec90a2a00799c274c4ebe0d548d6ae5805ffbfb295f7957813f496bf83c6ddc9e3cc4dcaad814517bcf1c8dbe8b1ec22299a7dc894149
pkgname = tsubasa
diff --git a/PKGBUILD b/PKGBUILD
index 6a81b853f6e3..2c3b6b6c82a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,22 @@
# Maintainer: TheBitStick <the at bitstick dot rip>
pkgname=tsubasa
-pkgver=0.1.1
-pkgrel=2
-pkgdesc="Script for sharing screenshots and/or status updates using ihabunek/toot"
+pkgver=0.1.3
+pkgrel=1
+pkgdesc="Script for sharing screenshots and/or status updates"
arch=('any')
url="https://github.com/thebitstick/tsubasa"
license=('GPL3')
-depends=('fish' 'gnome-screenshot' 'zenity')
+depends=('fish' 'gnome-screenshot' 'zenity' 'toot')
makedepends=('git')
provides=('tsubasa')
conflicts=('tsubasa')
source=("$url/archive/$pkgver/$pkgname-$pkgver.tar.gz")
-sha512sums=('61dfc737f4a2a3737a31323e2a85fabc857a14f2d81f61303ab24a42f38c2d0da637b18381c5d51afbd543901c493f026779719638f109ea6ca2cdf0eb333235')
+sha512sums=('3e682bd1626b1e4df72ec90a2a00799c274c4ebe0d548d6ae5805ffbfb295f7957813f496bf83c6ddc9e3cc4dcaad814517bcf1c8dbe8b1ec22299a7dc894149')
package() {
cd "$pkgname-$pkgver"
install -D -t "$pkgdir/usr/bin" "tsubasa.fish"
+ install -D -t "$pkgdir/usr/share/applications" "tsubasa.desktop"
mv "$pkgdir/usr/bin/tsubasa.fish" "$pkgdir/usr/bin/tsubasa"
}