summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorthebitstick2020-04-21 20:21:33 -0500
committerthebitstick2020-04-21 20:21:33 -0500
commitff879e0e63c0325e608e567fb0132f43bbd6103e (patch)
treeeb068f2db8569f9442931f1dbe1cba1c7115abeb
downloadaur-ff879e0e63c0325e608e567fb0132f43bbd6103e.tar.gz
First commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD21
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f0c349b2da18
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = tsubasa
+ pkgdesc = Script for sharing screenshots and/or status updates using ihabunek/toot
+ pkgver = 0.1.1
+ pkgrel = 2
+ url = https://github.com/thebitstick/tsubasa
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = fish
+ depends = gnome-screenshot
+ depends = zenity
+ provides = tsubasa
+ conflicts = tsubasa
+ source = https://github.com/thebitstick/tsubasa/archive/0.1.1/tsubasa-0.1.1.tar.gz
+ sha512sums = 61dfc737f4a2a3737a31323e2a85fabc857a14f2d81f61303ab24a42f38c2d0da637b18381c5d51afbd543901c493f026779719638f109ea6ca2cdf0eb333235
+
+pkgname = tsubasa
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a81b853f6e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: TheBitStick <the at bitstick dot rip>
+pkgname=tsubasa
+pkgver=0.1.1
+pkgrel=2
+pkgdesc="Script for sharing screenshots and/or status updates using ihabunek/toot"
+arch=('any')
+url="https://github.com/thebitstick/tsubasa"
+license=('GPL3')
+depends=('fish' 'gnome-screenshot' 'zenity')
+makedepends=('git')
+provides=('tsubasa')
+conflicts=('tsubasa')
+source=("$url/archive/$pkgver/$pkgname-$pkgver.tar.gz")
+sha512sums=('61dfc737f4a2a3737a31323e2a85fabc857a14f2d81f61303ab24a42f38c2d0da637b18381c5d51afbd543901c493f026779719638f109ea6ca2cdf0eb333235')
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ install -D -t "$pkgdir/usr/bin" "tsubasa.fish"
+ mv "$pkgdir/usr/bin/tsubasa.fish" "$pkgdir/usr/bin/tsubasa"
+}